:focus { -moz-outline-style: none; } doesn't remove dotted borders when clicking on links/image links

RESOLVED INVALID

Status

()

RESOLVED INVALID
9 years ago
9 years ago

People

(Reporter: davidzou2131, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6

Since Firefox 3.6, :focus { -moz-outline-style: none; } does not work anymore as a CSS declaration.

Dotted red and blue lines appear around links and linked images.

Reproducible: Always

Steps to Reproduce:
1.http://david2131.com/index.php contains the declaration
2.Click on one of the tabs or links on the page and you should get dotted lines around what you clicked.
Actual Results:  
Get dotted lines around links.

Expected Results:  
Should not have shown the dotted lines around the links when ":focus { -moz-outline-style: none; }" is used in the script.

Comment 1

9 years ago
The error console reports:
Warning: Unknown property '-moz-outline-style'.  Declaration dropped.
Source File: http://david2131.com/index.php
Line: 13

That is to be expected, as support for -moz-outline-** was removed in bug 458588.
You should use 'outline', without the vendor prefix.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

9 years ago
OK, thanks for that.

use:

:focus {outline-style: none;}
Resolution: INVALID → FIXED

Comment 3

9 years ago
Please don't change the resolution.
'Fixed' would mean some code changes on the Gecko/Firefox side.
'Invalid' means this is not a bug in the Gecko/Firefox code.
Resolution: FIXED → INVALID
You need to log in before you can comment on or make changes to this bug.