"ASSERTION: New (SVG > 1.1) SVG viewport establishing element?"

RESOLVED FIXED in mozilla13

Status

()

Core
SVG
RESOLVED FIXED
8 years ago
6 years ago

People

(Reporter: Jesse Ruderman, Assigned: heycam)

Tracking

(Blocks: 2 bugs, {assertion, testcase})

Trunk
mozilla13
assertion, testcase
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
Created attachment 423739 [details]
testcase

###!!! ASSERTION: New (SVG > 1.1) SVG viewport establishing element?: 'Error', file /Users/jruderman/mozilla-central/layout/svg/base/src/nsSVGUtils.cpp, line 533
(Assignee)

Updated

6 years ago
Assignee: nobody → cam
Status: NEW → ASSIGNED
(Assignee)

Comment 1

6 years ago
Created attachment 594620 [details] [diff] [review]
Don't treat <svg:image> as a viewport establishing element.

I think it makes sense just to have <image> not be considered to be a viewport
establishing element.  It does establish a viewport but for the referenced
document, not child content in this document.
Attachment #594620 - Flags: review?(jwatt)
(Assignee)

Updated

6 years ago
Whiteboard: [autoland-try]

Updated

6 years ago
Whiteboard: [autoland-try] → [autoland-in-queue]

Comment 2

6 years ago
Autoland Patchset:
	Patches: 594620
	Branch: mozilla-central => try
	Destination: http://hg.mozilla.org/try/rev/70fc825a5a84
Try run started, revision 70fc825a5a84. To cancel or monitor the job, see: https://tbpl.mozilla.org/?tree=Try&rev=70fc825a5a84

Comment 3

6 years ago
Try run for 70fc825a5a84 is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=70fc825a5a84
Results (out of 208 total builds):
    success: 188
    warnings: 20
Builds (or logs if builds failed) available at:
http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/autolanduser@mozilla.com-70fc825a5a84

Updated

6 years ago
Whiteboard: [autoland-in-queue]
Comment on attachment 594620 [details] [diff] [review]
Don't treat <svg:image> as a viewport establishing element.

Yeah, agreed. Can you add an explanatory comment to nsSVGUtils::EstablishesViewport noting this though? (Maybe with a pointer to this bug.)
Attachment #594620 - Flags: review?(jwatt) → review+
(Assignee)

Comment 5

6 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/e3744914228d
Flags: in-testsuite+
OS: Mac OS X → All
Hardware: x86 → All
Target Milestone: --- → mozilla13

Comment 6

6 years ago
https://hg.mozilla.org/mozilla-central/rev/e3744914228d
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.