https does not load or returns blank - allows refreshing (!)

RESOLVED INCOMPLETE

Status

()

Firefox
General
RESOLVED INCOMPLETE
9 years ago
8 years ago

People

(Reporter: Mr Alexander, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2011-1-30], URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-GB; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-GB; rv:1.9.2) Gecko/20100115 Firefox/3.6

509034 is a bug report going towards that direction.

What happenns:  on logging into secure accounts pages, I get either a blank page (that I am allowed to refresh; i.e. it DOESN'T trigger e.g. the bank to ask you to go back to the inital login screen but insecurely allows the "back" and "refresh" browser buttons. - this implies to me incorrect encryption / lack of? / or low encryption).
Secondly, in the case freedompass.org, the entering of the tracking number draws a "blank"; unable to reproduce at the same time on Safari.

I have "downgraded" to 3.5.7, which behaves perfectly in all respects and.	 

Reproducible: Sometimes

Steps to Reproduce:
try the secure account pages.
Also, I submitted a survey and it did never say that I completed it but greeted me with a blank page.



Firefox 3.5.7 produces correct behaviour:  https banking sites will NOT permit "refresh" or "back" buttons on the browser, instead asking you to login back from the very start.  All surveys I have completed now run correctly.
3.6 has a bug pertaining to https and certain elements of http.

Comment 1

9 years ago
I have the exact same bug. On any https:// page there will be a blank page, no error messages.
Reporter, are you still seeing this issue with Firefox 3.6.13 or later in safe mode? If not, please close. These links can help you in your testing.
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Managing+profiles

You can also try to reproduce in Firefox 4 Beta 8 or later, there are many improvements in the new version, http://www.mozilla.com/en-US/firefox/all-beta.html
Whiteboard: [CLOSEME 2011-1-30]

Comment 3

8 years ago
Bug no longer exists in Firefox 3.6.13 in safe mode, but when not in safe mode the bug still happens.
Jake if this does not happen in safe mode then it is an extension causing the problem. Please disable them one by one until you find the problem cause, then report to it's developer.
No reply, INCOMPLETE. Please retest with Firefox 3.6.13 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 6

8 years ago
I think I have narrowed it down to "Perspectives", which "bypasses FIREFOX https security errors by verifying certificates..."  I have disabled it, and firefox 3.6.13 (current version) behaves correctly.

Comment 7

8 years ago
I can't exactly remember which add-on/extension it was but I deleted all my add-ons and the bug is gone. So I guess this can be closed?
You need to log in before you can comment on or make changes to this bug.