All users were logged out of Bugzilla on October 13th, 2018

Auto BCC to multiple addresses separated by ';' creates a malformed BCC header.

RESOLVED DUPLICATE of bug 258653

Status

--
minor
RESOLVED DUPLICATE of bug 258653
9 years ago
9 years ago

People

(Reporter: hcoscar, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; es-ES; rv:1.9.2) Gecko/20100115 Firefox/3.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; es-AR; rv:1.9.1.7) Gecko/20100111 Thunderbird/3.0.1

Hello,

   When you create an Acccount and set the auto BCC feature with multiple addresses separated by a semicolon ';' the compose window show a malformed header adding a " (double quote) character before the @ symbol to the first email adddress.

  NOTE: If you separate the addresses with ',' (comma) the feature works fine; that is, adding a new BCC field for each address.

Reproducible: Always

Steps to Reproduce:
1. In account manager, set you account to send automatic BCC copies to 2 or more email accounts, separating each address with a ';' semicolon.
2. Compose a new email message.
3. Look at the field of BCC's addresess.
Actual Results:  
While composing a new message, you will see that the first field for BCC's is malformed. What you get is something like :

BCC: user1"@domain.com; user2@domain.com

Note the " (double quote) before de @ symbol.

If you set more than two addresses you will see something like:

BCC: user1"@domain.com; user2@domain.com; user3@otherdomain.com; user4@otherdomain.com

If you set in account manager the addresses with mixed semicolons or commas like:

user1@domain.com; user2@domain.com, user3@otherdomain.com; user4@otherdomain.com

You get:

BCC: user1"@domain.com; user2@domain.com
BCC: user3"@otherdomain.com; user4@otherdomain.com

Another example:

user1@domain.com; user2@domain.com, user3@otherdomain.com, user4@otherdomain.com

BCC: user1"@domain.com; user2@domain.com
BCC: user3@otherdomain.com
BCC: user4@otherdomain.com

Expected Results:  
A single field for each BCC address or a single field for all addresses.

A workaround is adding your BCC addresses separated by commas instead of semicolons. The use of semicolon is as common as using a comma.
(Reporter)

Updated

9 years ago
Version: unspecified → 3.0
I can't tell if this is a bug in the Account Manager, or in the Message Compose Window. For that matter, it might even be in MailNews as a whole, not just TB. Whichever, I was able to confirm easily on Vista (Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.7) Gecko/20100111 Lightning/1.0b1 Thunderbird/3.0.1 ThunderBrowse/3.2.8.1 ID:20100111101938).
Severity: normal → minor
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 7 → All

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 258653
You need to log in before you can comment on or make changes to this bug.