Font-face does not load on subdomain of a domain

RESOLVED DUPLICATE of bug 536510

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 536510
8 years ago
8 years ago

People

(Reporter: Vesa Piittinen, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; fi; rv:1.9.2) Gecko/20100115 Firefox/3.6 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; fi; rv:1.9.2) Gecko/20100115 Firefox/3.6 (.NET CLR 3.5.30729)

When using @font-face to load a font that is on the same domain but on a different subdomain the font is not loaded. The font should be loaded.

Reproducible: Always

Steps to Reproduce:
1. Upload a font to http://domain.com/fontsname.ttf
2. Create a test page to load the font from the url above using @font-face.
3. Upload a test page to http://domain.com/test.html and http://sub.domain.com/test.html
Actual Results:  
The font displays on http://domain.com/test.html but does not in http://sub.domain.com/test.html

Expected Results:  
The font should display on sub.domain.com as it does in domain.com

All the other browsers allow displaying the font on a subdomain (IE6, IE7, IE8, Safari, Chrome, Opera).
(Reporter)

Comment 1

8 years ago
Sorry, should've noticed that this should go to the Core and not Firefox; newbie with bug reporting systems.
(Reporter)

Comment 2

8 years ago
Okay, after finding bug #536510 I finally got the information that this is related to https://developer.mozilla.org/En/HTTP_access_control#Access-Control-Allow-Origin

Just more work for me via .htaccess
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 536510
You need to log in before you can comment on or make changes to this bug.