Status

P2
critical
RESOLVED INVALID
9 years ago
8 years ago

People

(Reporter: dangoor, Assigned: jwalker)

Tracking

Details

(Reporter)

Description

9 years ago
On Mac OS X, there's a project called Growl which is a "notification router". 
If some Mac OS X application wants to tell you that something has happened, it 
can route that message through growl. Often, these notifications are displayed 
as popups that appear for a few seconds and then disappear. A great feature of 
Growl is the ability for the user to modify which notifications are displayed 
and how they are displayed.

We would like to offer similar functionality for Bespin. We would likely have 
three notification destinations to start with:

1. the command line output window
2. a SproutCore-based popup that displays in the Bespin window
3. Growl (or equivalent for Windows/Linux, if there is one). This requires 
additional plugin support (see below)

Gears and Jetpack (https://wiki.mozilla.org/Labs/Jetpack/JEP/34) offer 
notification APIs (which can actually tap into Growl!).

Part of the notification API has already been created by Joe Walker, but we 
want to flesh it out and provide the UI.
(Reporter)

Comment 1

9 years ago
Scheduling for 0.7 and bumping up the priority. This will be important for the 
ErrorStack integration.
Severity: normal → critical
Priority: -- → P1
Target Milestone: --- → 0.7.0
(Reporter)

Updated

9 years ago
Blocks: 550285
(Reporter)

Comment 2

9 years ago
Dropping to P2, since the reason I had elevated this was for ErrorStack 
integration and until I'm certain we can do that this is a little lower 
priority.
Priority: P1 → P2
(Reporter)

Updated

9 years ago
Target Milestone: 0.7.0 → ---
Assignee: nobody → jwalker
Status: NEW → ASSIGNED
Duplicate of this bug: 511266
(Reporter)

Comment 4

8 years ago
ACETRANSITION

The Skywriter project has merged with Ajax.org's Ace project (the full server part of which is their Cloud9 IDE project). Background on the change is here:

http://mozillalabs.com/skywriter/2011/01/18/mozilla-skywriter-has-been-merged-into-ace/

The bugs in the Skywriter product are not necessarily relevant for Ace and quite a bit of code has changed. For that reason, I'm closing all of these bugs. Problems that you have with Ace should be filed in the Ace issue tracker at GitHub:

https://github.com/ajaxorg/ace/issues
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.