[sl] Change search plug-ins for Firefox in Slovene

RESOLVED FIXED

Status

RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: mathjazz, Assigned: kinger)

Tracking

({productization})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(5 attachments, 6 obsolete attachments)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; sl; rv:1.9.2) Gecko/20100115 Firefox/3.6
Build Identifier: 

Slovenian Firefox 3.6 and Firefox Mobile use different search engines, so we would like to unify them. We've defined search engines for Firefox Mobile 1.0 in bug [522008]: 
https://bugzilla.mozilla.org/show_bug.cgi?id=522008

We would like to use the same in Firefox 3.6.1, namely:

- www.google.com
- www.ceneje.si
- www.odpiralnicasi.com
- sl.wikipedia.org
- twitter

For permissions and icons, see [522008].

Reproducible: Always
(Reporter)

Updated

9 years ago
Component: Localization → sl / Slovene
Product: Core → Mozilla Localizations
(Reporter)

Updated

9 years ago
Keywords: productization
(Reporter)

Comment 1

9 years ago
We would really like to change our search engines ASAP, preferably for the 3.6.1 release, because our current engines are the same as in Firefox 1.0, which means the choice has been made more than 5 years ago.

Ceneje.si is Slovenian online shopping meta-search engine and odpiralnicasi.com is Slovenian version of yelp.com, which is clear, easy to use, plus it supports geolocation.

The problem with current engines set is that we have two general search engines (Google and Najdi.si), but we only need one. So we would like to leave only Google and add Twitter in the social category.
(Assignee)

Updated

9 years ago
Assignee: nobody → brian
Summary: [sl] Choose search plug-ins for Firefox in Slovene → [sl] Change search plug-ins for Firefox in Slovene

Comment 2

9 years ago
Created attachment 424054 [details] [diff] [review]
ceneje.si search plugin

You're going to need to amend this patch similar to the instructions here:

https://bugzilla.mozilla.org/show_bug.cgi?id=522008#c41

We'll need to test this to make sure it works.
(Reporter)

Comment 3

9 years ago
Created attachment 424069 [details] [diff] [review]
Updated Ceneje.si search plugin for Firefox
(Reporter)

Comment 4

9 years ago
Seth, how do we test it?

Could you please also add xml description file for odpiralnicasi, because I can only see diff here:

https://bugzilla.mozilla.org/show_bug.cgi?id=522008#c33

Comment 5

9 years ago
Created attachment 424094 [details] [diff] [review]
Odpiralni Casi search plugin
(Reporter)

Comment 6

9 years ago
Stas, could you please take a look at this? We would like to have new search engines in the 3.6.1 release.

Comment 7

9 years ago
(In reply to comment #4)
> Seth, how do we test it?

You can install the .xml files locally to a "test" profile and test basic search terms with the new plugin.  I did this for both and it worked.

Comment 8

9 years ago
I am about to attach three files for you guys to test locally.  All should be correct for Firefox search.  You can test these buy downloading the .xml files and placing them in the search plugins folder of a Firefox test profile.  I have done that and they work for me.

Matjaž, your original Ceneji file had the icon size 32 x 32 but for browser search, it needs to be 16 x 16.  I also corrected my first Odpiralni Casi file to follow proper MozSearch format.  Finally, I am attaching a Twitter search plugin for Firefox for Slovenian.  In the search description of that file, you'll see that I used "Iskalnik Twitter" for "Search Twitter".  Please confirm that.  

Patch will follow after I attach the files for you to test locally.  OK?

Comment 9

9 years ago
Created attachment 425401 [details]
Updated Ceneje Mobile Search Plugin

The first Ceneji file had the icon size 32 x 32, but for browser
search, it needs to be 16 x 16.
Attachment #424054 - Attachment is obsolete: true
Attachment #424069 - Attachment is obsolete: true

Comment 10

9 years ago
Created attachment 425402 [details]
Updated Ceneje Search Plugin

My apologies.  Updating the name of the plugin to "Updated Ceneje Search Plugin".
Attachment #425401 - Attachment is obsolete: true

Comment 11

9 years ago
Created attachment 425403 [details]
Update Odpiralni Casi search plugin

Updated Odpiralni Casi file with proper MozSearch format.
Attachment #424094 - Attachment is obsolete: true

Comment 12

9 years ago
Created attachment 425405 [details]
sl Twitter search plugin

Comment 13

9 years ago
Created attachment 425411 [details] [diff] [review]
Amends list.txt and adds Ceneji, Odpiralni, and Twitter

You originally asked us to make the desktop browser list of search plugins match the mobile browser list of search plugins. However, this patch does not remove Yahoo from the list because we typically like to have two general purpose search engines for the desktop version.  If you choose to remove Yahoo, that's fine, but you'll have to also amend the region.properties file.
Attachment #425411 - Flags: review?(brian)

Comment 14

9 years ago
Created attachment 425412 [details] [diff] [review]
 Amends list.txt and adds Ceneji, Odpiralni, and Twitter   

Noticed a small error in my patch with the Twitter search plugin.  Please review this one.
Attachment #425411 - Attachment is obsolete: true
Attachment #425412 - Flags: review?(brian)
Attachment #425411 - Flags: review?(brian)
(Reporter)

Comment 15

9 years ago
Seth:

1. Thanks for your advice on testing the engines. All of them appear to be working fine!
2. "Iskalnik Twitter" is a great translation for "Search Twitter". Now you officially speak Slovenian.
3. Yes, we would like to remove Yahoo, because nobody uses it in Slovenia. I will attach the /browser/chrome/browser-region/region.properties file, if that is the one that has to be replaced.
(Reporter)

Comment 16

9 years ago
Created attachment 425423 [details]
/browser/chrome/browser-region/region.properties
(Reporter)

Comment 17

9 years ago
So my question is, what exactly do I need to change in this file, to remove Yahoo! completely?

Comment 18

9 years ago
Created attachment 425435 [details] [diff] [review]
Removed Yahoo from region.properties and list.txt; made one small correction with Odpiralni Casi search plugin

Matjaz:  To answer your question, you could have simply removed Yahoo from the search plugin order in the region.properties file.  That list overrides the alphabetical order of search plugins.  Google is always #1, Yahoo is typically #2.  I edited your region.properties file and also removed Yahoo from list.txt.

If this patch looks good to you guys, feel free to commit...and use Pike's sign off app!
Attachment #425412 - Attachment is obsolete: true
Attachment #425435 - Flags: review?(brian)
Attachment #425412 - Flags: review?(brian)
(Reporter)

Comment 19

9 years ago
Thank you very much, Seth!

Brian, could you commit please?
(Assignee)

Updated

9 years ago
Attachment #425435 - Flags: review?(brian) → review+
(Assignee)

Comment 20

9 years ago
Comment on attachment 425435 [details] [diff] [review]
Removed Yahoo from region.properties and list.txt; made one small correction with Odpiralni Casi search plugin

Checked in:

http://hg.mozilla.org/releases/l10n-mozilla-1.9.2/sl/rev/ee89bb24fc3c
(Assignee)

Comment 21

9 years ago
I've checked this in to mozilla-1.9.2 only. Does it need to go into any other tree?
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Assignee)

Comment 22

9 years ago
(In reply to comment #21)
> I've checked this in to mozilla-1.9.2 only. Does it need to go into any other
> tree?

Anyone?
Depends on whether you're actively working on l10n-central or not. We'll fork for 1.9.3 from either 1.9.2 or central, depending on what you're doing.
(Assignee)

Comment 24

9 years ago
Not actively working on l10n central, so this is FIXED.
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Thanks guys, I updated the l10n-src-verification in http://hg.mozilla.org/l10n/l10n-src-verification/rev/258d00f8f52d.
You need to log in before you can comment on or make changes to this bug.