Closed Bug 542792 Opened 10 years ago Closed 10 years ago

[OOPP] plugin-process crash [@ mozilla::plugins::PluginModuleChild::UnregisterActorForNPObject] (with foxit reader)

Categories

(Core :: Plug-ins, defect)

x86
Windows 7
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 544074
Tracking Status
blocking2.0 --- alpha2+

People

(Reporter: benjamin, Unassigned)

References

Details

Saw a set of crash reports using foxit reader at  	mozilla::plugins::PluginModuleChild::UnregisterActorForNPObject. These are probably all the same user.

mozilla::plugins::PluginModuleChild::UnregisterActorForNPObject(NPObject *)|hg:hg.mozilla.org/mozilla-central:dom/plugins/PluginModuleChild.cpp:e436d3c5a4a6|326|0x13 1|1|xul.dll|mozilla::plugins::PluginScriptableObjectChild::~PluginScriptableObjectChild()|hg:hg.mozilla.org/mozilla-central:dom/plugins/PluginScriptableObjectChild.cpp:e436d3c5a4a6|457|0xb 1|2|xul.dll|mozilla::plugins::PluginScriptableObjectChild::`vector deleting destructor'(unsigned int)|||0x7 1|3|xul.dll|mozilla::plugins::PluginInstanceParent::DeallocPStreamNotify(mozilla::plugins::PStreamNotifyParent *)|hg:hg.mozilla.org/mozilla-central:dom/plugins/PluginInstanceChild.cpp:e436d3c5a4a6|1007|0xd 1|4|xul.dll|mozilla::plugins::PPluginInstanceChild::DeallocSubtree()|hg:hg.mozilla.org/mozilla-central:obj-firefox/ipc/ipdl/PPluginInstanceChild.cpp:e436d3c5a4a6|1412|0xc 1|5|xul.dll|mozilla::plugins::PPluginInstanceChild::OnCallReceived(IPC::Message const &,IPC::Message * &)|hg:hg.mozilla.org/mozilla-central:obj-firefox/ipc/ipdl/PPluginInstanceChild.cpp:e436d3c5a4a6|948|0x9

Frame 3 is especially odd because it's claiming to call PluginInstanceParent::DeallocPStreamNotify, but I suspect that is just comdat-folding for PluginInstanceChild::DeallocPPluginScriptableObject.

Haven't tried to reproduce yet. There's a somewhat-similar crash with a slightly different stack at http://crash-stats.mozilla.com/report/index/418c812c-f4c3-4a1c-9a9d-6ffc12100126 running the Atok translator plugin (http://www.justsystems.com/jp/products/atok/)
Duplicate of this bug: 542780
I got the same problem in Window 7 x64, for now I disabled the plugin.
This blocks a1, if only to blacklist foxit reader.
blocking2.0: --- → alpha1
benjamin: hopefully you'd merely prevent it from being hosted by OOPP instead of actually blocking it.
I mean the OOPP blacklist, not the plugin blocklist.
blocking2.0: alpha1 → alpha2
I can't get foxit reader to work at all (win7), IPP or OOPP. The screen just stays white. Is there some trick to it?
I had to quit using Foxit way before OOPP was introduced because 99% of the time, the Foxit process would start, but nothing would show up in Firefox until I went and killed the Foxit process and refreshed the page. Normally the 2nd time would load the PDF.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 544074
You need to log in before you can comment on or make changes to this bug.