Closed Bug 542831 Opened 12 years ago Closed 11 years ago

[OOPP]Silverlight does not start play on certain page

Categories

(Plugins Graveyard :: Silverlight (Microsoft), defect)

x86
Windows 7
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: alice0775, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.2pre) Gecko/20100128 Firefox/3.6.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a1pre) Gecko/20100128 Minefield/3.7a1pre ID:20100128051129

set dom.ipc.plugins.enabled to true, Silverlight does not start play.

Reproducible: Always

Steps to Reproduce:
1.Start Minefiled + Silverlight 3.0.50106.0
2.Go URL ( http://silverlight.net/showcase/  )
3.
Actual Results:  
Silverlight does not start play

Expected Results:  
Silverlight start play

If i set dom.ipc.plugins.enabled to false, Silverlight will start play
Version: unspecified → Trunk
Yikes, lots of problems there. I get hangs, script errors, not playing silerlight, bug 535295 is showing up, lots of other stuff.
Safe mode in Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a1pre) Gecko/20100128 Minefield/3.7a1pre (.NET CLR 3.5.30729) ID:20100128051129.
Status: UNCONFIRMED → NEW
Ever confirmed: true
so is this not fixed with bug 540604 which landed yesterday?  It seems to work for me.
Ok, Confirming.


(In reply to comment #2)
> so is this not fixed with bug 540604 which landed yesterday?  It seems to work
> for me.

I just tested this and it was working before applying the new nightly and was running an hourly from last night, but now I see it doesn't load with the 20100128 nightly build.
Adding www.nbcolympics.com to list of sites that freeze up when playing video.

As soon as the video trys to load, the browser hangs/freezes.  Killing mozilla-runtime will restore the browser, then the site will starting tossing 'slow script errors'.  

Turning 'off' OOPP the site works OK. 

Note: when testing with Minefield you will have to spoof your UA.
Should probably set this to block OOPP.
(In reply to comment #4)
> Adding www.nbcolympics.com to list of sites that freeze up when playing video.
> 
> As soon as the video trys to load, the browser hangs/freezes.  Killing
> mozilla-runtime will restore the browser, then the site will starting tossing
> 'slow script errors'.  
> 
> Turning 'off' OOPP the site works OK. 
> 
> Note: when testing with Minefield you will have to spoof your UA.

bug 532208 - easy to reproduce on:

http://www.nbcolympics.com/video/assetid=d357e5ad-0e53-4156-9b34-cf2a1eca7656.html#wild+look+cross+crash
Confirming the original bug report. The plugin is running normally, but it looks like our load delay problems with silverlight (bug 547359?) might be interfering with script execution. I see javascript errors like this:

JavaScript error: http://blogs.silverlight.net/showcase/resources/js/main.js?fd=-8589467390013877770, line 3626: this._slPlugin.content is undefined

Probably not an alpha blocker.
I was testing today after the landing of cset: 
http://hg.mozilla.org/mozilla-central/rev/dc3af645f713

Which had some changes to what I think are OOPP changes, and the test URL given in the bug, the 'Showcase' page now does not load at all, and I get no slow-script warning as some were seeing before. 

This in Console2:

Error: this._slPlugin.content is undefined
Source file: http://blogs.silverlight.net/showcase/resources/js/main.js?fd=-8589467390013877770
Line: 3626



However, possible good news, is that the Olympics pages with video, now play smoothly here, without lockups, and even Full-screen plays well. 

Of course, IE8 works, win7 x64 here...
WFM, every time now. I don't get the stop script dialog either.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → WORKSFORME
Component: Plug-ins → Silverlight (Microsoft)
Product: Core → Plugins
QA Contact: plugins → microsoft-silverlight
Version: Trunk → unspecified
Unfortunately, testing even with SL4 for me, I still cannot get it to play most times using latest trunk.
Product: Plugins → Plugins Graveyard
You need to log in before you can comment on or make changes to this bug.