If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Adaptive Junk ignores "in address book". Adaptive junk occurs BEFORE Mail Filters (using global inbox)

RESOLVED WORKSFORME

Status

Thunderbird
Account Manager
--
major
RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: Bob Katz, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.1.7) Gecko/20100111 Thunderbird/3.0.1

Conditions: I am using the Global Inbox Account and this bug may only apply to that condition. My Junk filtering is ONLY enabled in the Local Folders account (as recommended in http://kb.mozillazine.org/Junk_Mail_Controls). Mail Filters are only being applied to the Local Inbox. In other words, there are no mail filters on the source mail accounts (I'm not sure what will happen if I also enable junk filtering on the source accounts).
The problems are multiple!!! If you wish to divide this report into separate bugs, caution as it all may be interactive. (Sorry). And to repeat,this bug may only apply when the user is using the Global Inbox.

1) Junk filtering is ignoring the exception "Do not mark mail as junk if the sender is in the address book (all address books are checked"". I've done extensive checking on this, and when I right click on an address in a message that's been marked as junk, Thunderbird wants to let me edit the contact, so it knows that the contact is in an address book.
2) Junk Filtering appears to be occurring BEFORE message filtering. In other words, messages are landing in junk that should have been prefiltered before being junked. But according to:  http://kb.mozillazine.org/Junk_Mail_Controls
the order of processing is supposed to be:  
1) Message Filters
2) Trust headers assigned by Spam Assassin
3) Adaptive Junk Processing

As a test, if I go into my junk folder and select a message that should have been filtered and not marked as junk and "run filters on message" or "run filters on folder", it gets filtered properly. If I forward this message to myself as a test message, it does not get filtered into the proper folder,it gets moved to junk, so all indications are that junk is taking precedence over filtering, which is wrong.

Reproducible: Always




You are welcome to contact me directly at bobkatz@digido.com for any tests or further information.

Comment 1

8 years ago
I've done some testing on your issues, and let me give you some comments. These tests are all with POP3 using a global inbox.

First, the address book issue. I tested this, and whitelisting works as expected. But something that you need to know is that in TB3, if you receive email that is purportedly from yourself, we will not whitelist that, as spoofing the from as equaling the to is very easy to do, and commonly done by spammers. So to test whitelist, you have to send using a "From" address that is not your own address. This feature can be disabled with a preference by the way. If you are still having problems with this, and have confirmed using addresses that are not your own, I suggest that you load the JunQuilla extension (which makes it clearer when a message is marked as good or junk, and why) and give more details in this bug.

As to the second issue, filtering DOES occur before junk processing by default (though this can be changed on a per-filter basis by marking the filter as "post classification"). But as you note, when the message is moved to the new folder, it still gets junk processed in that new folder. That happens after the filtering, but the result is the same. There are two ways to accomplish your goal, that moved messages are not processed as junk. First, you can mark the message not junk in the filter action. Second, if you load the JunQuilla extension, then you can specify that certain folders (or a tree of folders) are not processed for junk.
(Reporter)

Comment 2

8 years ago
Mr. Kent's comments are VERY helpful. This "bug" that I reported may amount to incomplete Thunderbird documentation which can now be easily fixed. It seems logical that the problem I'm encountering is the "secondary" junk filtering that's occuring AFTER the message filtering. Let's close this bug, please. If I still encounter a problem after trying Mr. Kent's recommendations I'll reopen it. 

Since he is clearly an expert, would Mr. Kent be so kind as to add his last paragraph's suggestions to the Mozilla documentation on junk, http://kb.mozillazine.org/Junk_Mail_Controls. I think that will help many more  determined users and avoid further bug reports along this line. 

Thanks again,

Bob

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.