All my add-ons show the following message: "Requires additional items. Disabled for your protection. Known to cause security or stability issues."

RESOLVED WORKSFORME

Status

()

Toolkit
Add-ons Manager
RESOLVED WORKSFORME
9 years ago
9 years ago

People

(Reporter: Tihomir, Unassigned)

Tracking

1.9.1 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7

They all seem to work, but it's worrying me. It happened after a crash when I was updating Flash and restarting FF.

Reproducible: Couldn't Reproduce
What addons do you have installed? Try updating firefox to 3.6, then let us know what happens.
Component: Extension Compatibility → Add-ons Manager
Product: Firefox → Toolkit
QA Contact: extension.compatibility → add-ons.manager
Version: unspecified → 1.9.1 Branch
This could happen if you are using a broken theme.
(Reporter)

Comment 3

9 years ago
Well, I have a lot of add-ons installed, but I've seen this issue
before being reported in FF 2.0, so I guess it's some sort of rarely
encountered database corruption bug. FWIW, the theme I've been using
has given me absolutely no trouble for the past year, and it seems
well supported. I've just updated to FF 3.6, and it was fixed. I guess
the add-on database or XML got renewed or something. Can you tell me
what the update process does to the database? I'm hardly a good
programmer, and even less so database tech, but this bug seems
interesting. May be a source of whole bunch of mysterious corruption
bugs. Here is the crash report ID:
1357a4da-9aca-4ce2-9cc3-969529d83d04. Thank you for reacting so
quickly. It's very reassuring. Best of luck!
Sounds like this is working now and unless you can still reproduce it we can't investigate this problem further.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.