Move abListOverlay.xul to suite/ or merge it into abMailListDialog.xul/abEditListDialog.xul

RESOLVED DUPLICATE of bug 555452

Status

SeaMonkey
MailNews: Address Book & Contacts
--
minor
RESOLVED DUPLICATE of bug 555452
8 years ago
4 years ago

People

(Reporter: InvisibleSmiley, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
Following up on bug 540444:

Both SM and TB have their own version of abMailListDialog.xul and abEditListDialog.xul. SM additionally uses abListOverlay.xul for both which currently lives in /mailnews even though it's not shared with TB. The file should either be moved to /suite or merged into SM's abMailListDialog.xul and abEditListDialog.xul (the only consumers).

<http://mxr.mozilla.org/comm-central/search?string=abListOverlay.xul>

Comment 1

8 years ago
I'm not sure that the minimal perf win warrants duplicating the abMailListDialog.xul code into its current consumers.

Given that both current consumers are almost identical, it'd be more useful to integrate the abEditListDialog.xul usecase into abMailListDialog.xul, but even that surely isn't an overly important task.

Let's just move the file here.

Comment 2

4 years ago
File was moved in Bug 555452
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 555452
You need to log in before you can comment on or make changes to this bug.