Compacting messages marked for deletion on IMAP sometimes randomly transforms other messages

RESOLVED WORKSFORME

Status

Thunderbird
Mail Window Front End
--
critical
RESOLVED WORKSFORME
9 years ago
8 years ago

People

(Reporter: Jason, Unassigned)

Tracking

({dataloss})

x86
Windows 7
dataloss

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2010-12-21][dupme])

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-GB; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT

I mark messages for deletion on my IMAP system. I press 'compact' to delete them permanently. Sometimes another message NOT marked for deletion has its body content (but not it's header or sender) transformed into the body content of another, again un-deleted, message, leaving me with two messages which used to be entirely different but now with the same body text. The body text of the transformed message cannot be retrieved in any obvious way and is lost forever. 

Reproducible: Sometimes

Steps to Reproduce:
1.Press 'compact'
2.Check to see whether anything has been transformed. 
3.
Actual Results:  
Sometimes messages bodies are transformed as described; other times, nothing changes. There is no discernible pattern. 

Expected Results:  
'Compact' should have deleted the messages marked for deletion and left everything else unchanged. This is what happened with the x-punge add-on in Thunderbird 2 and it worked amazingly well. Never were there any problems. 

I wanted to continue to use x-punge on TB3 but it would not install the add-on for some reason - said it was incompatible or somesuch - so I used 'compact' instead which I read was supposed to work in the same way.
(Reporter)

Updated

9 years ago
Flags: blocking-thunderbird3.1?
(Reporter)

Comment 1

9 years ago
I have checked with the web-based IMAP e-mail client and the warped body text in TB3 is NOT reproduced there (in the original, as 'twere), so it seems that the warping is JUST a problem with TB3. Clearly that poses no threat to messages stored on an IMAP server but what about messages stored locally which are organised by TB3? What is the risk of data transformation/loss there?
I have the distinct feeling that this is a duplicate of some existing bug, but can't find it. (If someone else could do the job and hunt it down, that'd be great! I suspect GloDa, but am not sure.)

Have you tried going offline and looking at the corrupted messages?

By the way, Xpunge is now compatible (as of probably sometime in the last week or so), so if you want to, you can try that instead.
Severity: critical → major
Component: Message Reader UI → Mail Window Front End
Keywords: dataloss
QA Contact: message-reader → front-end
Whiteboard: dupeme
Version: unspecified → 3.0
(In reply to comment #0)
> leaving me with two messages which used to be entirely different but now with the same body text.
> The body text of the transformed message cannot be retrieved in any obvious way and is lost forever. 

Show "Order Received" column(UID of mail if IMAP).
Duplicate UID? Or each mail has different UID(unique UID)?

Do you set "offline use=on" for the IMAP folder? If yes, check top part of offline-store file.
Mail data at offset-set=ZERO is displayed? If yes, see bug 501851. Same problem?
If no, which mail's data on offline-store file is displayed for the transformed message?
We don't generally block on bugs in the UNCONFIRMED state or that don't clear steps to reproduce that a developer could use in working on a fix.  Removing blocking nomination for the moment; feel free to renominate if both those conditions become fulfilled.
Flags: blocking-thunderbird3.1?

Comment 5

8 years ago
Jason ...


(In reply to comment #3)
> (In reply to comment #0)
> > leaving me with two messages which used to be entirely different but now with the same body text.
> > The body text of the transformed message cannot be retrieved in any obvious way and is lost forever. 
> 
> Show "Order Received" column(UID of mail if IMAP).
> Duplicate UID? Or each mail has different UID(unique UID)?
> 
> Do you set "offline use=on" for the IMAP folder? If yes, check top part of
> offline-store file.
> Mail data at offset-set=ZERO is displayed? If yes, see bug 501851. Same
> problem?
> If no, which mail's data on offline-store file is displayed for the transformed
> message?
Severity: major → critical
Whiteboard: dupeme → [closeme 2010-12-21][dupme]
(Reporter)

Comment 6

8 years ago
This has now fixed itself for me. It's been a long while (many months - maybe even January/February) that it hasn't done anything so I'm presuming that one of the updates, or maybe even your advice above, eliminated it. Thanks for all your help!

Comment 7

8 years ago
Thanks Jason. WFM per reporter
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.