Format submenus do not indicate current style of selection

VERIFIED FIXED

Status

()

Core
Editor
P2
major
VERIFIED FIXED
17 years ago
16 years ago

People

(Reporter: Frank Tang, Assigned: Kathleen Brade)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [rtm++]Patch attached)

Attachments

(6 attachments)

(Reporter)

Description

17 years ago
This is using Window commercial Netscape 6 bulid 2000092408
on Window NT4

repreduce procedure
1. launch Netscape6
2. Select "Task:composer" to open a new page.
3. type "abcdefg"
4. select "abc"
5. select "Format:Text Style:Bold"
6. the text "abc" display as bold
7. select "Format:Text Style" menu
expect result-
the menu item "Bold" show a check mark or some other indication to tell the 
user the current select text is in "Bold"

actual result-
no indication to tell user what the current state is.
"Format:Paragraph", "Format:List" and "Format:Align" menu do indicate the 
current state. 
"Format:Font" (as 54316) and "Format:Size" (as 54315)does not do this neither. 
Will report 
seperate bug for them.
(Reporter)

Comment 1

17 years ago
This problem can be reproduce on 20000927 Win/Linux build. But it is ok on Mac
build.

Comment 2

17 years ago
futuring, not sure who the owner of this is.

anthonyd
Target Milestone: --- → Future

Comment 3

17 years ago
there should be checkmark next to the style of the current selection, i thought 
that that used to be the case
Assignee: beppe → cmanske
Keywords: correctness, regression

Comment 4

17 years ago
This one is trivial. low risk/high visibility.
The menuitems were missing the 'type="checkbox"' attribute, which is needed
in order to have the checkmark visible.
Nominating for rtm fix.
Status: NEW → ASSIGNED
Keywords: rtm
Target Milestone: Future → M19

Comment 5

17 years ago
Created attachment 15761 [details] [diff] [review]
Fix for bug: simply add 'type="checkbox"' on menuitems

Comment 6

17 years ago
Created attachment 15867 [details] [diff] [review]
Fix for missing feedback in all Format submenus (fixes 54315, 54316, and 54317)

Comment 7

17 years ago
If bugs 54315 and 54316 are also approved or merged with this bug to cover
all missing submenu feedback issues, use the 9/29 patch, which fixes all 3
bugs.
Patch has been sent to Composer group for more testing and reviews.

Comment 8

17 years ago
Created attachment 15880 [details]
Test cases for Font face, size and text styles user feedback in Format submenus

Comment 9

17 years ago
The attached test file works for bugs 54315 and 54316 as well.
Handing off to Kathy as I'm starting my sabatical.
Assignee: cmanske → brade
Status: ASSIGNED → NEW

Comment 10

17 years ago
the user needs to be able to determine the style information from the menu, ther 
e is no text property dialog, consequently there is no workaround, this is a 
highly visible function.

Kathy, please include the required information per the rtm checkin rules
Priority: P3 → P2
Whiteboard: [rtm+ NEED INFO]Patch attached

Comment 11

17 years ago
PDT agrees [rtm need info] until code reviews are done
Whiteboard: [rtm+ NEED INFO]Patch attached → [rtm NEED INFO]Patch attached

Updated

17 years ago
Keywords: mailtrack
(Assignee)

Comment 12

17 years ago
Created attachment 16236 [details] [diff] [review]
patch as before but with additional fixes for Macintosh
(Assignee)

Comment 13

17 years ago
Created attachment 16237 [details] [diff] [review]
JS patch (part 2 of 2)
(Assignee)

Comment 14

17 years ago
I have attached new patches (2 separate attachments) because Charley's fixes
didn't work on Macintosh.  Apparently all radio menu items need to specify a
name (at least that is true on Macintosh).

Because I can't review my additional changes, I need reviews from both kin and
sfraser (one as sr and one as module owner).

There is no impact to i18n/l10n.
This is a very visible bug that seriously impacts editing in both Composer and
mail compose (the user has no feedback or incorrect feedback).
Severity: normal → major
Status: NEW → ASSIGNED
OS: Windows NT → All
Hardware: PC → All
(Assignee)

Comment 15

17 years ago
correcting summary to agree with the real problems addressed in this bug
Kin did a review and we agreed to one small change to the JS patch (part 2 of 2)
submitted 10/05/00 10:51.  I will attach the new diff for completeness

Kin--please add your sr= comment
Summary: Format:Text Style menu do not indicate the current style of the selected text → Format submenus do not indicate current style of selection
Whiteboard: [rtm NEED INFO]Patch attached → [rtm+]Patch attached
(Assignee)

Comment 16

17 years ago
Created attachment 16326 [details] [diff] [review]
replacement JS patch (part 2 of 2)
(Assignee)

Comment 17

17 years ago
*** Bug 54315 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 18

17 years ago
*** Bug 54316 has been marked as a duplicate of this bug. ***

Comment 19

17 years ago
r=kin@netscape.com

sfraser said he wanted to take a look at the new diffs which brade just posted 
(10/06/00 06:01.

Comment 20

17 years ago
r=sfraser

Comment 21

17 years ago
sr=sfraser
(Assignee)

Comment 22

17 years ago
note: the correct patches for this bug are dated:
  10/05/00 10:50  and 10/06/00 06:01

I'll send this off to pdt.
Keywords: patch

Comment 23

17 years ago
rtm++
Whiteboard: [rtm+]Patch attached → [rtm++]Patch attached
(Assignee)

Comment 24

17 years ago
Fix checked into branch before today's builds.
(Assignee)

Comment 25

17 years ago
fix now checked into trunk; resolving bug
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 26

17 years ago
verified in 10/10 build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.