Placeholder '?' leads to malfunction in javascript command using Firefox 3.6

RESOLVED INVALID

Status

()

RESOLVED INVALID
9 years ago
8 years ago

People

(Reporter: mbecker, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2011-1-30], URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1.7) Gecko/20091221 Ant.com Toolbar 1.4 Firefox/3.5.7 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1.7) Gecko/20091221 Ant.com Toolbar 1.4 Firefox/3.5.7 (.NET CLR 3.5.30729)

The following javascript-procedure

if(!parent.xaranshopframesetgeladen)
{
ziel = "index.htm?" + document.URL;
parent.location.replace(ziel);
}

results in an endless loop documented within the address-line like that:

...colorado-shop.de/index.htm?http://www.colorado-shop.de/xaranshop_09.htm

after trying to reach colorado-shop.de, a shop system unfortunately composed using frame-sets. Pls don't hit me, I'm only the user of that system. ;)

BR
Martin

Reproducible: Always

Steps to Reproduce:
1. goto http://www.colorado-shop.de - it's evident
2. no further step necessary
3.
Actual Results:  
Firefox 3.6 isn't able to load the frameset
Reporter, are you still seeing this issue with Firefox 3.6.13 or later in safe mode? If not, please close. These links can help you in your testing.
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Managing+profiles

You can also try to reproduce in Firefox 4 Beta 8 or later, there are many improvements in the new version, http://www.mozilla.com/en-US/firefox/all-beta.html
Whiteboard: [CLOSEME 2011-1-30]
(Reporter)

Comment 2

8 years ago
The problem has been resolved by new version of shop-software not further using frames. Because no old published version exists I'm not able to reproduce the error described and hope it's obsolete across the board. Not knowing how to close I mark it as invalid and resolved.

Happy New Year
Martin
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.