If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Bespin loads readme.txt upside down and discolored and eventually crashes Mobile Safari on iPhone 2G 3.1.2

RESOLVED DUPLICATE of bug 543250

Status

Skywriter
General
RESOLVED DUPLICATE of bug 543250
8 years ago
8 years ago

People

(Reporter: Vitorio, Unassigned)

Tracking

0.4.4
Other
Other

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7
Build Identifier: 0.4.4

On a fresh boot of the iPhone (2G, OS 3.1.2), I start Mobile Safari, visit bespin.mozilla.com, log in, and Bespin comes up.

The four-button splash image appears.  I can two-finger zoom to get to the X to close it.

On the desktop, readme.txt subsequently loads, but on the iPhone, it doesn't appear to.  Panning around, I can get glimpses of it in black text and upside down (see attached screenshot), but the text disappears when the panning stops, and I never see "Sample Project - readme.txt" at the top of the screen (also in attached screenshot).

I never get the iPhone keyboard to appear.  Tapping on the the ">" icon to bring up the command line does bring up the iPhone keyboard, but Mobile Safari crashes back to the Springboard shortly thereafter.

Reproducible: Always

Steps to Reproduce:
1. Log into Bespin
2. Close the splash window
3. Tap the ">" icon

Actual Results:  
readme.txt doesn't load, occasionally visible upside down and in black text

Command-line crashes Mobile Safari

Expected Results:  
Bespin should have worked perfectly ;)
(Reporter)

Comment 1

8 years ago
Created attachment 424434 [details]
broken rendering on Mobile Safari on iPhone 2G 3.1.2
(Reporter)

Comment 2

8 years ago
It seems, at least, that Bespin isn't able to fully load.  From the Mobile Safari debug console (any typos are mine, I'm transcribing):

JavaScript Log on Line 8
https://bespin.mozill...opup.js?1264885950119
refreshProjects

JavaScript Log on Line 16
https://bespin.mozilla.com/js/editor_all.js
qi deps:

JavaScript Log on Line 16
https://bespin.mozilla.com/js/editor_all.js
Checking

JavaScript Log on Line 16
https://bespin.mozilla.com/js/editor_all.js
Module:

JavaScript Log on Line 16
https://bespin.mozilla.com/js/editor_all.js
/getscript/js/bespin/editor/filepopup.js module has arrived

JavaScript Log on Line 16
https://bespin.mozilla.com/js/editor_all.js
Module:

JavaScript Log on Line 16
https://bespin.mozilla.com/js/editor_all.js
Queued /getscript/js/bespin/editor/filepopup.js for load

JavaScript Log on Line 16
https://bespin.mozilla.com/js/editor_all.js
/getscript/js/bespin/cmd/commandline.js module has arrived

JavaScript Error on Line 16
https://bespin.mozilla.com/js/editor_all.js
Unable to load before timeout: /getscript/js/bespin/cmd/commandline.js

JavaScript Log on Line 16
https://bespin.mozilla.com/js/editor_all.js
qi deps:

JavaScript Log on Line 16
https://bespin.mozilla.com/js/editor_all.js
Checking

JavaScript Log on Line 16
https://bespin.mozilla.com/js/editor_all.js
Module:

JavaScript Log on Line 16
https://bespin.mozilla.com/js/editor_all.js
/getscript/js/bespin/editor/popup.js module has arrived

JavaScript Log on Line 16
https://bespin.mozilla.com/js/editor_all.js
Queued /getscript/js/bespin/editor/popup.js for load

JavaScript Log on Line 16
https://bespin.mozilla.com/js/editor_all.js
Queued /getscript/js/bespin/cmd/commandline.js for load
Not sure what is going on with this bug, but the code you're using is quite old. The best thing I can say right now is to be on the lookout for the upcoming 0.7 deployment on the Mozilla Labs server. (No specific date available.)

When that deployment happens, please come back and let us know if this issue is still occurring.
Version: unspecified → 0.4.4
(Reporter)

Comment 4

8 years ago
I'm working on debugging this issue with Bespin Embedded (bug #543250), so marking it as a duplicate of that bug.
(Reporter)

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 543250
You need to log in before you can comment on or make changes to this bug.