Bookmarks can not be moved (only copied) by dragging from a bookmarks search

RESOLVED FIXED in Firefox 69

Status

()

enhancement
P2
normal
RESOLVED FIXED
10 years ago
4 days ago

People

(Reporter: snoopy565656, Assigned: mihir17166)

Tracking

unspecified
Firefox 69
Points:
---

Firefox Tracking Flags

(firefox68 wontfix, firefox69 fixed)

Details

(Whiteboard: [fxsearch])

Attachments

(1 attachment)

Reporter

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1.7) Gecko/20091221 Firefox/3.0.5, Ant.com Toolbar 1.1 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1.7) Gecko/20091221 Firefox/3.0.5, Ant.com Toolbar 1.1 (.NET CLR 3.5.30729)

After opening the "Library" page with Bookmarks\Organize Bookmarks it is possible to organize bookmarks by dragging them from the list on the right side into a folder in the treeview at the left side. This will result in a move of the bookmark, which is as expected.

But if any string is entered in the "Search Bookmarks" field in the top right
corner, to filter the list of displayed bookmarks, then it is no more possible
to MOVE the bookmarks by dragging. Dragging will lead to a COPY of the bookmark.

In this case it should also be possible to MOVE bookmarks by dragging
(e.g. using the Ctrl-Key, Shift-Key,... while dragging).
This would enhance organizing bookmarks a lot.

Reproducible: Always

Steps to Reproduce:
1. Open the "Library" page with Bookmarks\Organize Bookmarks
2. Enter any string in the "Search Bookmarks" field in the top right
corner, so that bookmarks are listed.
3. Drag a bookmark to a folder in the treeview at the left side.
Actual Results:  
This will create a copy of the bookmark.

Expected Results:  
The result is o.k., but it seems that is is not possible to override this behaviour using the Ctrl, Shift or Alt-Key (or any other method) to get a move of the bookmark.
It should also be possible to MOVE bookmarks by dragging
(e.g. using the Ctrl-Key, Shift-Key,... while dragging).
yes, searches are considered read-only so a copy is forced, it should probably be possible to still allow d&d of a real bookmark it it comes out of a query, that would make the code a bit more complex probably, forcing a query refresh and losing a bunch of things.

But probably that would make also the experience a bit confusing since once moving i expect something to disappear from here and appear there, with a query that would not happen. One could add a "open containing folder" option and go to the parent, but it's clearly not a nice experience to move more than 1 bookmark.

btw, confirming the enh request.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

8 years ago
Duplicate of this bug: 641029
Summary: Bookmarks can not be moved (only copied) by dragging when "Search Bookmarks" is active → Bookmarks can not be moved (only copied) by dragging from a bookmarks search

Updated

8 years ago
Duplicate of this bug: 663652

Updated

7 years ago
Duplicate of this bug: 747230
Priority: -- → P3
Duplicate of this bug: 1439192
Duplicate of this bug: 1008754
Priority: P3 → P2
Whiteboard: [fxsearch]

Comment 7

Last year
I really wish this was a higher priority. It gets incredibly frustrating.

This is exacerbated by the fact that the search list doesn't show the bookmarks current location, so you first have to open the link, then click on the blue star, and only then can you move it. Plus, the very limited navigation of locations in the drop down means it's often easier to then go find the bookmark manually in the sidebar (once the location is known) and then move it. Since otherwise you have to open a dialog to get full access to all the possible folders you have.

I didn't used to have to worry about this, since the combination of the All-in-one sidebar and add bookmark here 2 extensions gave me the ability to manage my bookmarks much more easily. Unfortunately the new extension format killed off both of those.

Updated

9 months ago
Duplicate of this bug: 1494886
This bug and most of the bugs marked as duplicates of it involve drag-and-drop. There is also a somewhat separate and newer issue which was touched on in bug #1494886, but wasn't elaborated on.

Cutting and pasting a bookmark from the search results (i.e., by using Ctrl+X, then Ctrl+V) would correctly move the bookmark in 57.0.4 (I tested 20180103231032) and for many versions previous (I know it worked at least since late 2015).

By 58.0b3 (I tested 20171114032831), the same action results in a copy. This behavior still exists in 64.0a1 20181021100205.


Example steps to reproduce:
1. Open the bookmark library (the one that can be accessed with Ctrl+Shift+B)
2. Add a bookmark to "Other Bookmarks"
3. Search for the bookmark that was just created by using the "Search Bookmarks" field at the top-right
4. Cut the bookmark shown in the results (by Ctrl+X or by the "Cut" option in the menu)
5. Select the "Bookmarks Menu" folder from the tree on the left
6. Paste the bookmark (by Ctrl+V or by the "Paste" option in the menu)

Expected results:
The bookmark should have been moved into the "Bookmarks Menu" folder.

Actual results:
The bookmark has been copied and now exists in "Other Bookmarks" and "Bookmarks Menu".
Duplicate of this bug: 1514593
See Also: → 1533339

Mihir is currently looking into this.

Assignee: nobody → mihir17166
Attachment #9067628 - Attachment description: Bug 543314 - Bookmarks can not be moved (only copied) by dragging from a bookmarks search. r?Standard8 → Bug 543314 - Allow bookmarks to be moved (as well as copied) from a bookmarks search. r?Standard8

I've just approved Mihir's patch and posted it in the check-in queue. I think we'll let this roll out through the trees rather than uplifting it for 68 for potential ESR inclusion. Whilst I don't expect there to be issues with the patch itself, this could enable some things we haven't thought about, so I'd rather have time for testing there.

Thank you Mihir for working on this. It is great to get this landed.

OS: Windows XP → All
Hardware: x86 → All

Comment 14

5 days ago
Pushed by mbanner@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/23597b843a4b
Allow bookmarks to be moved (as well as copied) from a bookmarks search. r=Standard8

Comment 15

4 days ago
bugherder
Status: NEW → RESOLVED
Closed: 4 days ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 69
You need to log in before you can comment on or make changes to this bug.