Cannot login to Add-On Collector on Multiple machines, but CAN login to my account online with same credentials

RESOLVED WONTFIX

Status

P2
normal
RESOLVED WONTFIX
9 years ago
3 years ago

People

(Reporter: patrick, Assigned: mackers)

Tracking

unspecified
BW-2.1
x86_64
Windows 7

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-GB; rv:1.9.2) Gecko/20100115 Firefox/3.6 (.NET CLR 3.5.30729)
Build Identifier: Add-on Collector 1.04

When going into my Extensions, and then "Subscriptions", I am asked to login to Add-on Collector.

However, using my correct credentials, every time I click to submit, the wait timer spins, and then drops me back to the login again, with no action ensuing.

Alternatively, on other machines, it drops me back to the login, but clears the password field.

The behaviour seems to differ across machines.

Whatever the case, the credentials ARE correct, and moreover, can reaily be used to log in to my account on the web itself via addons.mozdev

Reproducible: Always

Steps to Reproduce:
1. Go to Tools > Add Ons
2. Choose "Subscriptions" tab
3. Enter Login Credentials Correctly
4. Wait short time for wait timer to spin
5. User is then 'dropped' right back to where he was, with user credentials already filled in, or on some machines, the password field instead gets blanked.
Actual Results:  
I get 'dropped' back to needing to enter my login details... and on and on, over and over again

Expected Results:  
It should have happily logged me in with the credentials being correct, and then let me view my Subscriptions
Component: Collections → Collector Extension
QA Contact: collections → collector-extension

Updated

9 years ago
Assignee: nobody → brian
Target Milestone: --- → BW-1.0.5

Updated

9 years ago
Severity: major → normal
Target Milestone: BW-1.0.5 → BW-Future

Comment 1

9 years ago
Patrick,

Can you still reproduce this in v1.1 released yesterday?

Updated

9 years ago
Target Milestone: BW-Future → BW-1.1.2

Comment 2

8 years ago
Same problem - cannot login with "subscriptions" tab on firefox 3.6.4(Fedora) 3.6.7(Fedora) 3.6.8(Gentoo) on latest version of addon.

We tried this for two accounts - one created at july 2010 (occulkot) and the other created in 2008 (danmol).

After giving correct e-mail and password it looks like login service tries to connect to addon login service and we get error "There was an error logging in. Please check that your username and password are correct". Which im 100% sure are - because i even tried to copy them once to www auth on addons.mozilla (with successfuly logging in) and to subscriptions tab (with error).

Comment 3

8 years ago
> After giving correct e-mail and password it looks like login service tries to
> connect to addon login service and we get error "There was an error logging in.
> Please check that your username and password are correct". Which im 100% sure
> are - because i even tried to copy them once to www auth on addons.mozilla
> (with successfuly logging in) and to subscriptions tab (with error).


After few tests with disabling addons we figured out that this problem is caused by vimperator. After disabling vimperator we could succesfuly loged in and when we turn back vimperator on everything works fine.

Ive submited another bug to vimperator issues.
http://code.google.com/p/vimperator-labs/issues/detail?id=365&colspec=ID%20Summary%20Project%20Type%20Status%20Priority%20Stars%20Owner

Comment 4

7 years ago
Clash with Vimperator ... lets see if we can do something our end anyway.
Assignee: briks.si → dave
Status: UNCONFIRMED → NEW
Ever confirmed: true
Target Milestone: BW-1.1.2 → BW-2.1

Updated

7 years ago
Priority: -- → P2

Comment 5

7 years ago
2.1 is being released soon and it will be the final version of the Collector in its current form (A simple add-on just to load the Collections AMO page might replace it). This bug won't make it in. So marking this as WONTFIX.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.