[RFE] Method to allow administrators with standard user accounts to do updates

RESOLVED DUPLICATE of bug 529746

Status

()

Toolkit
Application Update
--
enhancement
RESOLVED DUPLICATE of bug 529746
8 years ago
8 years ago

People

(Reporter: Jack Eidsness, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a1pre) Gecko/20100130 Minefield/3.7a1pre (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a1pre) Gecko/20100130 Minefield/3.7a1pre (.NET CLR 3.5.30729)

I've read some heated discussions about the issue of unprivileged user accounts and updates, but I think I have a happy medium.  The most basic element is that unprivileged users can't do updates, and in the win XP era, almost everyone was an administrator.  Now that UAC has been around for three years, it seems clear that Firefox's behavior is not the best it could be.
It's hard to please everyone, so I will begin by listing the groups of people that I think we could please, by their concerns:
1) Truly unprivileged users (who only have a "standard" account) should not be bothered more than necessary;  With UAC in the world, you can't tell who these people are without asking them once.
2) Administrators running as an administrator obviously have no problem now and are unlikely to have any problems from any reasonable changes.
3) Administrators that choose to run as a standard user ("recommended" but I get the impression nobody does it because of software like firefox that requires extra steps). Currently they are treated the same as group 1.
3a) Windows Vista/7 users that find it easy to switch accounts/privileges
3b) Windows XP users that have to manually initiate an account switch (I don't know how this works or if anyone does that)



Reproducible: Always

Steps to Reproduce:
Click Help -> Check for Updates..., and even if you have a UAC system and an administrator account, it shuts you down.
Actual Results:  
The current behavior (Show the update button, or a message and give up) only satisfies groups 1 and 2.  With the exception of Group 3b, the current behavior seems as good as it could get for pre-vista windows users.
Furthermore, it seems odd that after doing an update as an administrator, it then restarts the browser as the administrator account, which most likely has a bare uncustomized user profile, and all you do is quit anyway.

Expected Results:  
My suggestion is changes to combine the "Unable to Update" and normal update dialogs and the method of updating.

The first change is to add an "I have no administrator account" button that deletes the download (if already downloaded) and suppresses update popups.  Help -> "Check For Updates ..." should remain available for if their situation changes.

The second change is to make sure we get the UAC icon over the button to apply a downloaded update.  Since Windows Vista, the UAC shield icon over a button has made it clear to users that an action is potentially available, if administrator account is available.
In order for that to work, we would need a process to apply the update as an administrator, and wait to restart the browser as the standard user.  Since there has to be two processes going at once, I'll refer to them as restarter which is unprivileged, and updater, which will run as an administrator.  The current updater starts firefox when it is done, so it would have to stop doing that, but otherwise, it should do what it's always done.  The restarter would spawn the updater, and initiate a UAC prompt at that time.  It would wait for the updater to finish, then finally restart firefox (unprivileged).
For standard accounts on pre-UAC systems, the current behavior ("Unable to Update" dialog) has to stay.  These users might be Type 1 (no admin account), or they might be 3b (must manually switch accounts), but we have no way to tell and nothing that can be done about it because of the OS.
(Reporter)

Comment 1

8 years ago
The "I have no administrator account" button might also be okay for pre-UAC users.  I'm having trouble coming up with a better phrasing that would not give a sense of approval to a cessation of updates, but merely indicate that it is not the right situation to initiate the process (even if it may be the right person).

Comment 2

8 years ago
Isn't this bug 404541 ? Is this a brand new Firefox 3.7 installation, or an old one that was upgraded ?
Component: Installer → Application Update
Product: Firefox → Toolkit
QA Contact: installer → application.update
There are already individual bugs for each supported platform for this functionality. I'll add your suggestions as to how to accomplish this to the relevant win32 bug which is bug 529746
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 529746
(Reporter)

Comment 4

8 years ago
Thanks for finding that and copying my suggestion!  All my searches had hinged on the word "admin" or "administrator" in the title.
You need to log in before you can comment on or make changes to this bug.