If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Firefox hangs on phpmyadmin SQL export page

RESOLVED WORKSFORME

Status

()

Firefox
General
--
major
RESOLVED WORKSFORME
8 years ago
7 years ago

People

(Reporter: Stephen, Unassigned)

Tracking

({hang, perf})

3.6 Branch
x86
Mac OS X
hang, perf
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_2; en-US) AppleWebKit/532.5 (KHTML, like Gecko) Chrome/4.0.249.49 Safari/532.5
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6

I was using phpmyadmin to export a database on-screen. When I initially clicked the export button it tool about 10 seconds for the exported SQL frame to show. Once it did, I clicked inside the frame to select all, and the browser hung. I had multiple tabs open (at least 15) at the time. It then came back from 100% CPU usage, and I could use all the other tabs, but when I click inside the SQL text iFrame, it hangs again for another 5 minutes.

Reproducible: Always

Steps to Reproduce:
1. Export a database to screen in phpmyadmin
2. click inside the iFrame
3. browser hangs
(Reporter)

Comment 1

8 years ago
I just exited FF, and the re-started it. Tried the phpmyadmin export again without any other tabs open. Same result.
Can you please test in safe mode? http://support.mozilla.com/en-US/kb/Safe+Mode
Severity: normal → major
Keywords: hang
Summary: Firefox crashes on phpmyadmin SQL export page → Firefox hangs on phpmyadmin SQL export page
Version: unspecified → 3.6 Branch
(Reporter)

Comment 3

8 years ago
Same results. Although this time it let me click inside the frame without issue (i think), but when I did ctrl-A it hung, consuming 100% cpu.
(Reporter)

Comment 4

8 years ago
I guess this could be an issue with the size of the database I am viewing. It has some fairly large data sets in it, but I would want firefox to be a little more graceful about displaying/selecting large content.
Stephen, is it better with version 4 beta? http://www.mozilla.com/firefox/beta/
Keywords: perf
(Reporter)

Comment 6

7 years ago
This issue appears to be resolved in the version 4 beta. I just tested it and was able to click on the text area after the export with no lockup.
(Reporter)

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.