table "jumps" when chaning bgcolor via javascript

VERIFIED FIXED

Status

()

Core
Layout
P3
normal
VERIFIED FIXED
18 years ago
17 years ago

People

(Reporter: Henrik Gemal, Assigned: karnaze (gone))

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
This bug is pretty weird, but here we go:
If you go to:
http://gemal.dk/util/bgcolor.html
and note when the top table start. Now press on one of the colors and watch the 
entire table jumps a bit up.
(Reporter)

Comment 1

18 years ago
Created attachment 15606 [details]
Screen shot of before and after the change of bgcolor. The red line shows that the entire table jumps up!

Comment 2

18 years ago
Triaging Clayton's list... (sorry for d'spam)
Assignee: clayton → attinasi

Comment 3

18 years ago
Good news and bad news: First the good news, the problem is not with changing 
the bgColor, it is with these two lines of script:

document.color.colorname.value = ColorName;
document.color.colorrgb.value = ColorRGB;

Remove them and no jumping. I dont know what those lines are suppossed to do, so 
please explain and I'll try to direct the bug toward the correct module.

Bad news: The test page looks positively awful in NS6 B3 (build from 9-29). It 
looks much nicer in Nav4. In Mozilla, each color square is large and has text in 
it, in nav they are nice and small and have no text. I'm CC'ing buster since I 
believe this may have to do with MAP / AREA handling...

Buster, please check this site out and see if related to MAP changes.

Comment 4

18 years ago
Actually, never mind Buster, I'm pretty sure this has nothing to do with MAPS, 
but rather the ALT attribute. sorry, I jumped the gun.

Comment 5

18 years ago
Created attachment 15992 [details]
Local copy of the page in question

Comment 6

18 years ago
Chris, this sure looks like an incremental reflow problem with tables. Note that
in the attached local copy of the page I removed the bgcolor from the <BODY> so
now you have to pick 2 colors before it jumps - strange. Also, the comments I
made on the 29th all appear to be bogus - must have had a bad lunch ;)

Sorry I cannot narrow this down further for you.
Assignee: attinasi → karnaze
(Reporter)

Comment 7

17 years ago
seems to be fixed in todays build....
20010302...
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 8

17 years ago
Marking verified per last comments
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.