Closed Bug 543489 Opened 10 years ago Closed 10 years ago

deb repacks need access to dpkg-deb

Categories

(Release Engineering :: General, defect)

ARM
Maemo
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 506989

People

(Reporter: aki, Assigned: aki)

References

Details

Our current method of repacking is broken -- it's no longer seen as a valid deb, and won't show up in update repositories.

The fix is to use dpkg-deb instead of re-ar-ing the files.

We need to have dpkg-deb on the linux systems.  Not sure if this is available for CentOS or if we need to change the maemo l10n repacks to use scratchbox.
why did it break? what changed?
The l10n repos either broke when we changed the commands to try to fix the app name/icon, or never worked at all.

Stuart found this on Friday: http://wilmer.gaast.net/blog/archives/3-.deb-files-are-ar-archives,-but-....html
Depends on: 544031
In bug 538699 I tried to get repacks working outside of scratchbox again, and due to libhildonsomething + dpkg-deb had to use scratchbox.

Since bug 506989 dealt with that, reopening that and duping this to it.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 506989
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.