destroyed name while reply with geman umlauts in from-name

RESOLVED DUPLICATE of bug 491832

Status

Thunderbird
Message Compose Window
RESOLVED DUPLICATE of bug 491832
9 years ago
9 years ago

People

(Reporter: Reindl Harald, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; de; rv:1.9.2) Gecko/20100121 Remi/fc11 Firefox/3.6
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.7) Gecko/20100120 Fedora/3.0.1-1.fc11 Lightning/1.0b2pre Thunderbird/3.0.1

If i get mails from persons with german "umlauts" like" AFI Klöckl
<mailaddress>" with some CC-addresses and use "reply all" i get a scary result:

To: AFI =?iso-8859-1?q?Kl=F6ckl=22?= <mailaddress>
CC: AFI =?iso-8859-1?q?Kl=F6ckl=22?= <emailaddress>, cc-address1, cc-address2

* To-Field looks like destroyed, so i manually fix this
* The to-adress is multiplied in the cc-field, also destroyed

Strange is that this does not happen if the same name/address-combination is in
the cc-field in a message from another person

This behavior was the first time in TB 3.0 and is also in TB 3.0.1


Reproducible: Always

Steps to Reproduce:
* Receive a mail with üöä in from-name
* Use "reply" or "reply all"
Actual Results:  
Destroyed name and original sender in same destroyed way in to AND cc

Expected Results:  
Not destroyed names
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 491832
You need to log in before you can comment on or make changes to this bug.