[BLOCK] command line arg "-url" doesn't work.

VERIFIED FIXED in M8

Status

P1
blocker
VERIFIED FIXED
20 years ago
14 years ago

People

(Reporter: phillip, Assigned: radha)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

20 years ago
Overview Description:
        the command line option -url is now ignored when apprunner is
        invoked from command line.

Steps to Reproduce:
	1) in a command shell, type `./apprunner -url http://www.mozilla.org`
	2) note that navigator.xul is used to create the ui.

Actual Results:

	Navigator has an empty url and displays no page, but does use
	Navigator.xul.

Expected Results:

	Navagator should use have loaded mozilla.org's homepage after it loaded
	navigator.xul. (either that, or their should be some way to specify
	which file to use for your UI and which url you'd like as the default
	location.)

Build Date & Platform:
	4/23/99 build on RedHat Linux 5.2
	4/22/99 (17) build on Win NT 4.0 sp4.

Updated

20 years ago
Assignee: don → radha
Priority: P3 → P1
Summary: [block]command line arg "-url" doesn't work. → [BLOCK] command line arg "-url" doesn't work.
Target Milestone: M5

Comment 1

20 years ago
Assigned to radha.

Radha, is this problem also due to Rod's changed?

Updated

20 years ago
Assignee: radha → rods

Comment 2

20 years ago
Re-assigned to rods.

Rod, you want to mark this one fixed now?

Updated

20 years ago
Assignee: rods → radha

Comment 3

20 years ago
Re-assigned to radha.

Oops. I re-assigned the wrong one to Rod ...
Status: NEW → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → FIXED
I fixed it few minutes ago. This is because of some checkin by Bill that I
mentioned yesterday.

Updated

20 years ago
QA Contact: 3853 → 4078

Comment 5

20 years ago
Updating QA Contact
(Reporter)

Comment 6

20 years ago
ok, now -url works, but it does not serve to also load the navigator.xul file.

we need a way to pass a url to the xul file such that navigator can be launched
with its chrome AND with a default url.

is this hiding in the spec some where?
I tried this in today's build. With the -url option, I could see apprunner with
the chrome, menus etc...and the url passed as argument to -url option displayed
in the content area.  Now, I don't understand what you mean by "Loading a
default url". Are you talking about a default HOME page?
(Reporter)

Updated

20 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 8

20 years ago
i don't understand, but all of the sudden, this works. i'm not going to spend
too much more time trying to figure out why it didn't work before. i'll claim
lack of coffee.

the moral of the story is:
     `./apprunner -url http://www.mozilla.org` brings up a browser with chrome
     and the expected content on
     build 1999-04-26-09, RedHat Linux 5.2 i386
     build 1999-04-26-08, WinNT 4.0 sp4, i386
(Reporter)

Updated

20 years ago
Status: VERIFIED → REOPENED
(Reporter)

Comment 9

20 years ago
this no longer works on
	RedHat 5.2 build 1999-06-09-08
	WinNT 4.0  build 1999-06-09-08

what happens:

	the qa smoketest page is loaded from mozilla.org.

Expected Results:

	the specified url should be loaded.


this is blocking the automated smoke tests from working.
(Reporter)

Updated

20 years ago
Severity: major → blocker
Resolution: FIXED → ---
(Reporter)

Comment 10

20 years ago
clearing resolution, changing to blocker, cc'ing leaf and leger...

Updated

20 years ago
Component: Apprunner → XPApps
Target Milestone: M5 → M7

Comment 11

20 years ago
This is definitely not working as of this morning's builds; i didn't realize
this worked before, or the tree would still be closed.

apprunner -url "http://www.yahoo.com"
apprunner -url http://www.yahoo.com
apprunner "http://www.yahoo.com"

all fail for today's windows build. Without this feature, automated smoketests
are impossible. Radha, are you around to try and track this down?

Comment 12

20 years ago
Also blocking performance test scripts...arrggghh!  I pinged the pointy
heads...let's try for a fix today please :-)
Looking in to it.
Bill Law will checkin a fix in few minutes.

Comment 15

20 years ago
AWESOME!!! thanks mucho!

Updated

20 years ago
Status: REOPENED → RESOLVED
Last Resolved: 20 years ago20 years ago
Resolution: --- → FIXED

Comment 16

20 years ago
Bill just checked in the fix.
(Reporter)

Updated

20 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 17

20 years ago
verified
	RedHat 5.2,  build 1999-06-10-08
	WinNT 4 sp4, build 1999-06-10-09
(Reporter)

Updated

20 years ago
Status: VERIFIED → REOPENED
(Reporter)

Updated

20 years ago
Resolution: FIXED → ---
(Reporter)

Comment 18

20 years ago
i hate to do this, but this no longer works as of
	build 1999-07-02-10 on windows NT4 sp 4
	build 1999-07-02-11 on RedHat Linux 5.2
Target Milestone: M7 → M8
Status: REOPENED → RESOLVED
Last Resolved: 20 years ago20 years ago
Resolution: --- → WORKSFORME
Works for me in unix & windows in today's build Please verify.
(Reporter)

Updated

20 years ago
Status: RESOLVED → REOPENED
(Reporter)

Comment 20

20 years ago
this is fixed
(Reporter)

Updated

20 years ago
Status: REOPENED → RESOLVED
Last Resolved: 20 years ago20 years ago
Resolution: WORKSFORME → FIXED
(Reporter)

Updated

20 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 21

20 years ago
verified on
	RedHat 5.2   build 1999-07-06-16-M8
	WinNT 4.0sp4 build 1999-07-06-08-M8
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.