wrong From: address when reply/reply all from 2nd Account Sent Folder

RESOLVED DUPLICATE of bug 523339

Status

RESOLVED DUPLICATE of bug 523339
9 years ago
8 years ago

People

(Reporter: kennethjamesanthony, Unassigned)

Tracking

x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9.2) Gecko/20100124 Firefox/3.6 (Swiftfox) GTB7.0 (.NET CLR 3.5.30729)
Build Identifier: 3.0.1

If you have 2 emails accounts configured under thunderbird. When you have an existing sent email in the 2nd account and you open it and click reply/reply all.
The From address defaults to the first account's email address. It should be the corresponding email account.

Reproducible: Always

Steps to Reproduce:
1.Create 2 different email accounts in thunderbird.
2.From 2nd account send an email to anybody, copy is saved in sent folder.
3.Open up the email an click on reply/reply all.

Actual Results:  
From address defaults to the first account or 0 index of list.

Expected Results:  
From address should default to the corresponding sent folders account.
I can't reproduce with Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.7) Gecko/20100111 Lightning/1.0b1 Thunderbird/3.0.1 ThunderBrowse/3.2.8.1 ID:20100111101938. Are you opening the message in the preview pane, a new tab, or a new window?
OS: All → Linux
Hardware: All → x86_64
Version: unspecified → 3.0
(Reporter)

Comment 2

9 years ago
Yes, open a new window.
But my environment is my 2nd sent folder is a combination of 2 accounts using local folders. 


My First sent folder is set as default account.
(Reporter)

Comment 3

9 years ago
It does not matter if it is view in a new window, tab or preview.

Comment 4

9 years ago
I also have this problem (I'm running version 3.6.2). If you reply to a mail which is in Sent, it uses the wrong account to send from. I have more than two accounts and it appears to be inconsistent which one it chooses but it's always an unexpected one. My default account (which is never the one it chooses in these cases) is at the top of the account list and the one it seems to choose most often is the next one down. The accounts don't share any email addresses as identities (my default account has several, the erroneous account only one). Replies to Inbox and other mail boxes correctly pick up the erroneous account and identity.

Comment 5

9 years ago
Sorry, that should be 3.0.3 (3.6.2 was FF version which is irrelevant).
Tried reproducing this again. I have multiple accounts, including ones I'll call n32d (the default), FB, FB2, and bz; all of the test accounts use IMAP and SMTP.

Attempted STR:
0. Set FB2's Sent folder to be the same as FB's
1. Send a message from FB2 to bz
2. Wait for the message to be sent, received, downloaded, etc
3. Select the message in bz's Inbox
4. Click Reply in the message header
<check A>
5. Select the message in FB/FB2's Sent folder
6. Click Reply in the message header
<check B>

Actual:
At check A, message appears addressed from bz to FB2. At check B, message also appears addressed from bz to FB2.

Expected:
At check A, message should appear addressed from bz to FB2. At check B, message should also appear addressed from bz to FB2.

I am unable to reproduce any unexpected behavior with this setup. Any ideas on what I'm doing "wrong" (that is, an unexpected workaround or the like) that prevents me from seeing the bug?
So issues might involved mailing list and identities more than accounts.

Comment 8

9 years ago
(In reply to comment #6)
> ... <check A>

is no problem for me either: always works OK for Inbox messages.

> <check B>

It only goes wrong for me when I try to reply to (or forward) messages originally sent from my DEFAULT account (though using different identities in that default account). Perhaps that's the difference. Also, I'm not sending messages to (an alter ego) of myself, but to other people. I don't POP on the other accounts (another difference?), so I've never tested it sent to (another account for) myself. I'm also selecting the message to reply to in the common (smart folder) Sent folder (but I don't see a separate Sent in local folders anyway)

Here is a precise list of what I can do to reproduce it. I have accounts A (default), B, C. A has multiple identities. B and C have only one.

1. send email to someone@example.com using default account A
2. go to Sent folder 
3. select the message I just sent
4. Reply (or Forward).

Result: From shows as address for account B, or sometimes C. 

Note: there's no need to receive any messages to reproduce this.

I haven't determined any common factor for when it chooses C over B, but I'm sure there must be one.

There is no identity in account A with the same email address or even domain as the email address for B. But C does have a common domain name with a (non-default) identity in A, though again no common email address.

Incidentally, it isn't helpful that the To address is always me. Reply to All will give me To: me, CC: original recipients and ccs, but it would be much more helpful if it gave (for Reply) To: original recipients and for Reply All, To: original recipients CC: original CCs. That's a different but possibly related issue which I have a separate bug report for (https://bugzilla.mozilla.org/show_bug.cgi?id=497560 and it's not really a bug, as it's doing the same as any incoming message would, it is just not very helpful).

Finally, I suppose you might ask why I'm doing this at all? It's when I need to follow up on a message I sent; as I don't get messages I send come back to me, my only record of them is in the Sent folder and therefore that's the place I have to go to make an additional point to the original recipients.
Have you tried safe mode? (see https://support.mozillamessaging.com/en-US/kb/Safe+Mode for more information)

Comment 10

9 years ago
I didn't know there was such a thing. I have tried it now and the result is identical (i.e. the problem is still there as I described).

Comment 11

9 years ago
I am having similar problem, but messages are in Inbox, not Sent. OS is Windows. Problem is message dependent (two different messages in same Inbox, not appreciably different, one exhibits correct behaviour on Reply-to, other does not).

Mail for several email addresses is downloaded to one account, then copied via filters to other accounts' inboxes based on X-Apparently-To. The final account is configured in three separate ways to match the X-Apparently-To address (Account Settings: Email Address, Account Settings->Manage Identities: Multiple Identities Support and Server Settings: User Name)

However despite these three settings, and the X-Apparently-To value in the message, when I select Reply-To (either by right clicking on the folder detail line, right clicking on the fully displayed message, or selecting the Reply radio button) it selects as the From address, the email address of the account into which it was first dropped and then filtered out of.

Note: these settings were copied from the Netscape 7.4 settings (rather than being setting directly by me, and the problem did NOT happen in Netscape).

Comment 12

9 years ago
By the way, I believe this and 522665 are related. 522665 claims self is included in Reply to All and that is simply a side-effect of not recognizing that self should be the From address.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 523339
You need to log in before you can comment on or make changes to this bug.