Incorporate Firefox CD process into the release steps

RESOLVED WONTFIX

Status

Release Engineering
General
P5
enhancement
RESOLVED WONTFIX
8 years ago
5 years ago

People

(Reporter: lsblakk, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [simple])

The cdmaker scripts will soon be checked into hg and once they are it should be possible to set up a builder that can be (manually?) triggered after a release to create a .iso and put it up on ftp. This way all our future releases will have a corresponding CD image.
(Reporter)

Updated

8 years ago
Assignee: lsblakk → nobody
Component: Release Engineering: Future → Release Engineering
(Reporter)

Updated

8 years ago
Component: Release Engineering → Release Engineering: Future

Comment 1

8 years ago
Mass move of bugs from Release Engineering:Future -> Release Engineering. See
http://coop.deadsquid.com/2010/02/kiss-the-future-goodbye/ for more details.
Component: Release Engineering: Future → Release Engineering
Priority: -- → P3
(Reporter)

Updated

8 years ago
Severity: normal → enhancement
Priority: P3 → P5
(Reporter)

Updated

8 years ago
Duplicate of this bug: 511532
(Reporter)

Comment 3

8 years ago
Cdmaker scripts in hg.mozilla.org/build/tools
The CD is no longer in the store:
  http://intlstore.mozilla.org/index.php?cPath=1

Is there any desire to put it back there ?
FWIW, I'm not sure it makes sense to do this in a rapid release world, where the CD stock would be refreshed every 6 weeks. Did we ever ship enough units to justify the work involved ?

Comment 6

7 years ago
No strong desire to put the CD back in the store, mainly b/c of what Nick points out in comment #5. It would simply be *way* too much effort to justify it at this point.

If you need a CD for other purposes we can leave this bug open, but if it's primarily for the store I'm fine with a WONTFIX here.
Thanks John. We don't need a CD for anything else, so WONTFIX it is.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

5 years ago
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.