proxy configuration authentication popups even though details are saved

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
9 years ago
8 years ago

People

(Reporter: rochmind, Unassigned)

Tracking

3.6 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7

installed 3.6 today and corporate proxy authentication pops-up all the time even though it is saved in firefox. when opening a new tab to or entering new url, pops-up all the time.

regressed to 3.5.7 and problem disappeared. the same corporate settings and user credentials were used.

Reproducible: Always

Steps to Reproduce:
1.configure automatic proxy configuration (corporate firewall)
2.type user credentials on pop-up and save
3.open any web site outside domain
4.authentication pops up even though it is saved
Actual Results:  
you need to configure automatic proxy configuration and save the user credentials to be able to see that the pop-ups all the time

Expected Results:  
pop-up every new tab or while entering new URL

as per previous versions, just loads the saved user credentials for proxy

Comment 1

9 years ago
Same problem, revert to 3.8.5 and all OK
3.6 requires authentication on each transmission.
wegman@rtg

Comment 2

9 years ago
I have the same issue, however I am not using "Automatic Configuration".

I am using manual config to an authenticated proxy. Proxy credentials are listed in the firefox save password list, however each new request displays the "Authentication Required" dialog.
I am on Win7 Ultimate x64.

Comment 3

9 years ago
I am using JCIFS to authenticate users and I experience the same problem with Firefox on Win7. The authentication dialog appears again and again even though the credentials have been supplied already.

Comment 4

8 years ago
Reporter -> Are you still experiencing this issue with the latest version of Firefox 3.6.15? Does the issue occur with the latest nightly? http://nightly.mozilla.org/
Version: unspecified → 3.6 Branch
(Reporter)

Comment 5

8 years ago
(In reply to comment #4)
> Reporter -> Are you still experiencing this issue with the latest version of
> Firefox 3.6.15? Does the issue occur with the latest nightly?
> http://nightly.mozilla.org/

just tried 3.6.15 and it's working ok

Comment 6

8 years ago
Glad to hear it!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.