Two accounts in google apps not works

RESOLVED DUPLICATE of bug 303542

Status

RESOLVED DUPLICATE of bug 303542
9 years ago
6 years ago

People

(Reporter: zkizzik, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; es-CL; rv:1.9.2) Gecko/20100115 Firefox/3.6
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; es-ES; rv:1.9.1.7) Gecko/20100111 Thunderbird/3.0.1

If make two accounts of google apps dont work...
test@domain1 and test@domain2 with same server pop.gmail.com on port 993 not detect else change values the account crash.

Reproducible: Always

Steps to Reproduce:
1. Create a new account test@example.com with google apps, thunderbird find smtp example.com but is pop.gmail.com, change this to pop of gmail and change username "test" to "test@example.com".

2. Create a new account again but test@example2.com, use same server "pop.gmail.com" and username "test@example2.com"

3. Look the bug, have two account with same username, server, password and mail! dont have two accounts of googleapps :( .
Actual Results:  
thunderbird clone two accounts and not work
(In reply to comment #0)
> If make two accounts of google apps dont work...
> test@domain1 and test@domain2 with same server pop.gmail.com (snip)

Gmail has many domain names for a Gmail's service (e.g. imap.gmail.com and imap.googlemail.com for same Gmail IMAP service), and gmail permits both username@domain.com and username for login in some cases(POP3 may be so).
As for Gmail IMAP, Tb3 defines xxx@gmail.com with server name = imap.googlemail.com in my environment, if fully automatic setup.
And, Tb3 removes "@domain.com" part from username upon account definition, if login with test is posible.
So, next can happen in your case(same name, different domain);
 account1 : addr=tets@domain1.com, hostname=pop3.googlemail.com, username=test
 account2 : addr=tets@domain2.com, hostname=pop3.googlemail.com, username=test
Check account/server/identity definitions in your prefs.js.

Workaround:
(A) Define accout manually.
   - Account wizard, start account creation, "stop" immediately
   - Set server name(pop3.domain1.com), user name(test@domain1.com)
   - Manual Setup, change accout definition appropriately
(B) Repeat Edit/Re-test Configration, until required user name/server name
    is displayed by Tb after auto-check.
    If unwanted result(e.g. test instead of test@domain.com), change to
    required one, and Manual Setup.

As required Gmail's SMTP/POP3/IMAP setup is well documented(server name, port, SSL/TLS for IMAP, StartTLS for SMTP, ...), I think full manual setup(A) is far easier to understand what you are doing.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 303542
You need to log in before you can comment on or make changes to this bug.