Random test failure on try server windows in test_asyncadd.js and test_sync.js

VERIFIED DUPLICATE of bug 543101

Status

()

Core
Networking: JAR
VERIFIED DUPLICATE of bug 543101
8 years ago
8 years ago

People

(Reporter: Away for a while, Unassigned)

Tracking

Trunk
x86
Windows Server 2003
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
I've seen this failure too many times on the try server with completely different and unrelated patches.  It always happens on Windows, and happens quite frequently as well.

Example log:

http://tinderbox.mozilla.org/showlog.cgi?log=MozillaTry/1265065092.1265075334.2480.gz
WINNT 5.2 try hg unit test on 2010/02/01 14:58:12

NEXT ERROR TEST-UNEXPECTED-FAIL | e:\builds\slave\win32-unit\mozilla\objdir\_tests\xpcshell\test_zipwriter\unit\test_asyncadd.js | test failed (with xpcshell return code: 3), see following log:
  >>>>>>>
  ### XPCOM_MEM_LEAK_LOG defined -- logging leaks to c:\docume~1\cltbld\locals~1\temp\tmpstzjiw\runxpcshelltests_leaks.log
TEST-INFO | (xpcshell/head.js) | test 1 pending
TEST-INFO | (xpcshell/head.js) | test 2 pending
TEST-PASS | e:/builds/slave/win32-unit/mozilla/objdir/_tests/xpcshell/test_zipwriter/unit/test_asyncadd.js | [run_test : 105] true == true
TEST-INFO | (xpcshell/head.js) | test 2 finished
TEST-INFO | (xpcshell/head.js) | running event loop
TEST-PASS | e:/builds/slave/win32-unit/mozilla/objdir/_tests/xpcshell/test_zipwriter/unit/test_asyncadd.js | [anonymous : 62] 0 == 0
TEST-PASS | e:/builds/slave/win32-unit/mozilla/objdir/_tests/xpcshell/test_zipwriter/unit/test_asyncadd.js | [anonymous : 67] 3876 == 3876
TEST-PASS | e:/builds/slave/win32-unit/mozilla/objdir/_tests/xpcshell/test_zipwriter/unit/test_asyncadd.js | [anonymous : 73] true == true
TEST-PASS | e:/builds/slave/win32-unit/mozilla/objdir/_tests/xpcshell/test_zipwriter/unit/test_asyncadd.js | [anonymous : 77] 232 == 232
TEST-PASS | e:/builds/slave/win32-unit/mozilla/objdir/_tests/xpcshell/test_zipwriter/unit/test_asyncadd.js | [anonymous : 78] 232 == 232
TEST-PASS | e:/builds/slave/win32-unit/mozilla/objdir/_tests/xpcshell/test_zipwriter/unit/test_asyncadd.js | [anonymous : 79] 57912358 == 57912358
NEXT ERROR TEST-UNEXPECTED-FAIL | e:/builds/slave/win32-unit/mozilla/objdir/_tests/xpcshell/test_zipwriter/unit/test_asyncadd.js | 1265067750000 == 1265067750200 - See following stack:
JS frame :: e:\builds\slave\win32-unit\mozilla\testing\xpcshell\head.js :: do_throw :: line 202
JS frame :: e:\builds\slave\win32-unit\mozilla\testing\xpcshell\head.js :: do_check_eq :: line 232
JS frame :: e:/builds/slave/win32-unit/mozilla/objdir/_tests/xpcshell/test_zipwriter/unit/test_asyncadd.js :: anonymous :: line 81
TEST-INFO | (xpcshell/head.js) | exiting test
uncaught exception: [Exception... "Component returned failure code: 0x80520015 (NS_ERROR_FILE_ACCESS_DENIED) [nsIFile.remove]"  nsresult: "0x80520015 (NS_ERROR_FILE_ACCESS_DENIED)"  location: "JS frame :: e:/builds/slave/win32-unit/mozilla/objdir/_tests/xpcshell/test_zipwriter/unit/tail_zipwriter.js :: <TOP_LEVEL> :: line 47"  data: no]


NEXT ERROR TEST-UNEXPECTED-FAIL | e:\builds\slave\win32-unit\mozilla\objdir\_tests\xpcshell\test_zipwriter\unit\test_sync.js | test failed (with xpcshell return code: 3), see following log:
  >>>>>>>
  ### XPCOM_MEM_LEAK_LOG defined -- logging leaks to c:\docume~1\cltbld\locals~1\temp\tmp5_dj1u\runxpcshelltests_leaks.log
TEST-INFO | (xpcshell/head.js) | test 1 pending
TEST-PASS | e:/builds/slave/win32-unit/mozilla/objdir/_tests/xpcshell/test_zipwriter/unit/test_sync.js | [run_test : 70] 3876 == 3876
TEST-PASS | e:/builds/slave/win32-unit/mozilla/objdir/_tests/xpcshell/test_zipwriter/unit/test_sync.js | [run_test : 77] true == true
TEST-PASS | e:/builds/slave/win32-unit/mozilla/objdir/_tests/xpcshell/test_zipwriter/unit/test_sync.js | [run_test : 80] 232 == 232
TEST-PASS | e:/builds/slave/win32-unit/mozilla/objdir/_tests/xpcshell/test_zipwriter/unit/test_sync.js | [run_test : 81] 232 == 232
TEST-PASS | e:/builds/slave/win32-unit/mozilla/objdir/_tests/xpcshell/test_zipwriter/unit/test_sync.js | [run_test : 82] 57912358 == 57912358
NEXT ERROR TEST-UNEXPECTED-FAIL | e:/builds/slave/win32-unit/mozilla/objdir/_tests/xpcshell/test_zipwriter/unit/test_sync.js | 1265067750000 == 1265067750200 - See following stack:
JS frame :: e:\builds\slave\win32-unit\mozilla\testing\xpcshell\head.js :: do_throw :: line 202
JS frame :: e:\builds\slave\win32-unit\mozilla\testing\xpcshell\head.js :: do_check_eq :: line 232
JS frame :: e:/builds/slave/win32-unit/mozilla/objdir/_tests/xpcshell/test_zipwriter/unit/test_sync.js :: run_test :: line 84
JS frame :: e:\builds\slave\win32-unit\mozilla\testing\xpcshell\head.js :: _execute_test :: line 130
JS frame :: -e :: <TOP_LEVEL> :: line 1
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 543101
(Reporter)

Updated

8 years ago
No longer blocks: 438871
Whiteboard: [orange]
V.Duplicate
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.