Status

()

Core
JavaScript Engine
P3
normal
VERIFIED DUPLICATE of bug 53512
18 years ago
16 years ago

People

(Reporter: Alec Flett, Assigned: brendan)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
Whenever I load my Excite portfolio, I consistently crash - I think it's
actually opening a window on a timer. The Excite Portfolio will open a window
with the day's alerts if there are any.

I don't think this is really a JS engine bug, but it seems to be called from the
DOM code, so I'm assigning to brendan, and CC'ing danm because he's fixed weird
stuff like this before...


Here's the stack trace:
#0  0x40176f74 in js_NewContext (rt=0x81455f8, stackChunkSize=8192) at
jscntxt.c:91
#1  0x4016e963 in JS_NewContext (rt=0x81455f8, stackChunkSize=8192) at
jsapi.c:826
#2  0x40473888 in nsJSContext::nsJSContext (this=0x8884288, aRuntime=0x81455f8)
at nsJSEnvironment.cpp:312
#3  0x404790f3 in nsJSEnvironment::GetNewContext (this=0x8181870) at
nsJSEnvironment.cpp:1494
#4  0x4047912c in NS_CreateScriptContext (aGlobal=0x88841a8, aContext=0x8845258)
at nsJSEnvironment.cpp:1506
#5  0x40eba5d9 in nsDocShell::EnsureScriptEnvironment (this=0x88451a8) at
nsDocShell.cpp:4381
#6  0x40eabf1b in nsDocShell::GetScriptGlobalObject (this=0x88451a8,
aGlobal=0xbfffe0c0) at nsDocShell.cpp:2304
#7  0x4174e18e in DocumentViewerImpl::Init (this=0x872f398,
aParentWidget=0x883a600, aDeviceContext=0x87311d8, 
    aBounds=@0xbfffe1a4) at nsDocumentViewer.cpp:530
#8  0x40eafe3d in nsDocShell::SetupNewViewer (this=0x88451a8,
aNewViewer=0x872f398) at nsDocShell.cpp:2775
#9  0x40ebbdca in nsWebShell::SetupNewViewer (this=0x88451a8, aViewer=0x872f398)
at nsWebShell.cpp:350
#10 0x40eacab1 in nsDocShell::Embed (this=0x88451a8, aContentViewer=0x872f398,
aCommand=0x40ed5a04 "", aExtraInfo=0x0)
    at nsDocShell.cpp:2409
#11 0x40ebc02d in nsWebShell::Embed (this=0x88451a8, aContentViewer=0x872f398,
aCommand=0x40ed5a04 "", aExtraInfo=0x0)
    at nsWebShell.cpp:379
#12 0x40ead9fc in nsDocShell::CreateContentViewer (this=0x88451a8,
aContentType=0xbfffe42c "text/xul", 
    aOpenedChannel=0x88457a8, aContentHandler=0xbfffe49c) at nsDocShell.cpp:2588
#13 0x40ec4932 in nsDSURIContentListener::DoContent (this=0x8845320,
aContentType=0xbfffe42c "text/xul", aCommand=0, 
    aWindowTarget=0x40135028 "", aOpenedChannel=0x88457a8,
aContentHandler=0xbfffe49c, aAbortProcess=0xbfffe3e4)
    at nsDSURIContentListener.cpp:105
#14 0x40a03cb2 in nsDocumentOpenInfo::DispatchContent (this=0x88455d0,
aChannel=0x88457a8, aCtxt=0x0) at nsURILoader.cpp:359
#15 0x40a03277 in nsDocumentOpenInfo::OnStartRequest (this=0x88455d0,
aChannel=0x88457a8, aCtxt=0x0) at nsURILoader.cpp:233
#16 0x408a64ba in nsResChannel::OnStartRequest (this=0x88457a8,
transportChannel=0x8845c18, context=0x0) at nsResChannel.cpp:690
---Type <return> to continue, or q <return> to quit---
#17 0x4089aa82 in nsFileChannel::OnStartRequest (this=0x8845c18,
transportChannel=0x8845810, context=0x0)
    at nsFileChannel.cpp:633
#18 0x40818491 in nsOnStartRequestEvent::HandleEvent (this=0x884dbb8) at
nsAsyncStreamListener.cpp:210
#19 0x40817b76 in nsStreamListenerEvent::HandlePLEvent (aEvent=0x8845750) at
nsAsyncStreamListener.cpp:97
#20 0x400ef6de in PL_HandleEvent (self=0x8845750) at plevent.c:575
#21 0x400ef579 in PL_ProcessPendingEvents (self=0x89eebb8) at plevent.c:508
#22 0x400f1180 in nsEventQueueImpl::ProcessPendingEvents (this=0x8839e28) at
nsEventQueue.cpp:356
#23 0x40a6f80f in ?? () from
/export/alecf/seamonkey/mozilla/dist/bin/components/libwidget_gtk.so
#24 0x40a6f4cd in ?? () from
/export/alecf/seamonkey/mozilla/dist/bin/components/libwidget_gtk.so
#25 0x40c2b8da in ?? () from /usr/lib/libglib-1.2.so.0
#26 0x40c2cf96 in ?? () from /usr/lib/libglib-1.2.so.0
#27 0x40c2d561 in ?? () from /usr/lib/libglib-1.2.so.0
#28 0x40c2d614 in ?? () from /usr/lib/libglib-1.2.so.0
#29 0x40a70454 in ?? () from
/export/alecf/seamonkey/mozilla/dist/bin/components/libwidget_gtk.so
#30 0x405b0eca in ?? () from
/export/alecf/seamonkey/mozilla/dist/bin/components/libnsappshell.so
#31 0x405af480 in ?? () from
/export/alecf/seamonkey/mozilla/dist/bin/components/libnsappshell.so
#32 0x405a7bf0 in ?? () from
/export/alecf/seamonkey/mozilla/dist/bin/components/libnsappshell.so
#33 0x404a1708 in GlobalWindowImpl::OpenInternal (this=0x8629818, cx=0x862de98,
argv=0x88788a0, argc=3, aDialog=0, 
    aReturn=0xbfffecf8) at nsGlobalWindow.cpp:3032
#34 0x40498ae5 in GlobalWindowImpl::Open (this=0x8629818, cx=0x862de98,
argv=0x88788a0, argc=3, aReturn=0xbfffecf8)
    at nsGlobalWindow.cpp:2030
#35 0x4048398a in WindowInternalOpen (cx=0x862de98, obj=0x84b2828, argc=3,
argv=0x88788a0, rval=0xbfffeda0)
    at nsJSWindow.cpp:4195
#36 0x4018d9c6 in js_Invoke (cx=0x862de98, argc=3, flags=0) at jsinterp.c:820
#37 0x401967b2 in js_Interpret (cx=0x862de98, result=0xbffff2e8) at
jsinterp.c:2621
#38 0x4018ddff in js_Execute (cx=0x862de98, chain=0x84b2828, script=0x884aa20,
fun=0x0, down=0x0, special=0, result=0xbffff2e8)
    at jsinterp.c:992
#39 0x40172207 in JS_EvaluateUCScriptForPrincipals (cx=0x862de98, obj=0x84b2828,
principals=0x86d0590, chars=0xbffff4fc, 
    length=13, filename=0x86f1688
"http://quicken.excite.com/investments/portfolio/", lineno=175, rval=0xbffff2e8)
    at jsapi.c:3146
#40 0x404759a2 in nsJSContext::EvaluateString (this=0x8529178,
aScript=@0xbffff4e4, aScopeObject=0x84b2828, 
    aPrincipal=0x86d058c, aURL=0x86f1688
"http://quicken.excite.com/investments/portfolio/", aLineNo=175, 
    aVersion=0x401c2ba9 "default", aRetValue=@0xbffff44c,
aIsUndefined=0xbffff448) at nsJSEnvironment.cpp:583
#41 0x404a6361 in GlobalWindowImpl::RunTimeout (this=0x8629818,
aTimeout=0x86f1628) at nsGlobalWindow.cpp:3784
#42 0x404a6e19 in nsGlobalWindow_RunTimeout (aTimer=0x86d4010,
aClosure=0x86f1628) at nsGlobalWindow.cpp:4039
#43 0x419fb1fc in nsTimerGtk::FireTimeout (this=0x86d4010) at nsTimerGtk.cpp:185
#44 0x419fb3fe in process_timers (array=0x81e4fc8) at nsTimerGtk.cpp:254
#45 0x419fb4d6 in TimerCallbackFunc (data=0x818c880) at nsTimerGtk.cpp:281
#46 0x40c2de5d in ?? () from /usr/lib/libglib-1.2.so.0
#47 0x40c2cf96 in ?? () from /usr/lib/libglib-1.2.so.0
#48 0x40c2d561 in ?? () from /usr/lib/libglib-1.2.so.0
#49 0x40c2d701 in ?? () from /usr/lib/libglib-1.2.so.0
#50 0x40b55719 in ?? () from /usr/lib/libgtk-1.2.so.0
#51 0x40a703e4 in ?? () from
/export/alecf/seamonkey/mozilla/dist/bin/components/libwidget_gtk.so
#52 0x405b5ad5 in ?? () from
/export/alecf/seamonkey/mozilla/dist/bin/components/libnsappshell.so
#53 0x805256b in main1 (argc=1, argv=0xbffff8e4, nativeApp=0x0) at
nsAppRunner.cpp:1004
---Type <return> to continue, or q <return> to quit---
#54 0x8052ad2 in main (argc=1, argv=0xbffff8e4) at nsAppRunner.cpp:1185
#55 0x402f29cb in __libc_start_main (main=0x805297c <main>, argc=1,
argv=0xbffff8e4, init=0x804c1ac <_init>, 
    fini=0x805eae4 <_fini>, rtld_fini=0x4000ae60, stack_end=0xbffff8dc) at
../sysdeps/generic/libc-start.c:92
(Assignee)

Comment 1

18 years ago
Probably a dup of bug 53094.

/be

Comment 2

18 years ago
Stack trace looks identical to bug 53512 -

*** This bug has been marked as a duplicate of 53512 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 3

17 years ago
Verified dupe, based on stack trace.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.