If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Assertion failure: Thin_GetWait(tl->owner), at c:/mozilla/ff-dbg/js/src/../../../mozilla-central/js/src/jslock.cpp:1157 [@ThinUnlock]

RESOLVED DUPLICATE of bug 543839

Status

()

Core
JavaScript Engine
RESOLVED DUPLICATE of bug 543839
8 years ago
8 years ago

People

(Reporter: cjones, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

I hit this while loading

http://technet.microsoft.com/en-us/sysinternals/default.aspx

with a DEBUG build off of http://hg.mozilla.org/mozilla-central/rev/4ac114ee6247.

I've still got the crash in a debugger; I can keep it around for a while.  In the meantime I'll try to reproduce.

 	KernelBase.dll!7571194b() 	
 	[Frames below may be incorrect and/or missing, no symbols loaded for KernelBase.dll]	
>	mozjs.dll!JS_Assert(const char * s=0x684d5a24, const char * file=0x684d59e0, int ln=1157)  Line 67	C++
 	mozjs.dll!ThinUnlock(JSThinLock * tl=0x05748434, int me=40852968)  Line 1157 + 0x20 bytes	C++
 	mozjs.dll!js_DropAllEmptyScopeLocks(JSContext * cx=0x02888db8, JSScope * scope=0x05748428)  Line 1295 + 0x16 bytes	C++
 	mozjs.dll!js_GetMutableScope(JSContext * cx=0x02888db8, JSObject * obj=0x02981c00)  Line 132 + 0x40 bytes	C++
 	mozjs.dll!js_NonEmptyObject(JSContext * cx=0x02888db8, JSObject * proto=0x045bc2a0)  Line 3072 + 0x13 bytes	C++
 	024cf734()	
 	mozjs.dll!js::ExecuteTrace(JSContext * cx=0x02888db8, nanojit::Fragment * f=0x05c8e828, js::InterpState & state={...})  Line 6538 + 0x6 bytes	C++
 	mozjs.dll!js::ExecuteTree(JSContext * cx=0x02888db8, js::TreeFragment * f=0x05c8e828, unsigned int & inlineCallCount=0, js::VMSideExit * * innermostNestedGuardp=0x0018c200)  Line 6634 + 0x11 bytes	C++
 	mozjs.dll!js::MonitorLoopEdge(JSContext * cx=0x02888db8, unsigned int & inlineCallCount=0, js::RecordReason reason=Record_Branch)  Line 7128 + 0x15 bytes	C++
 	mozjs.dll!js_Interpret(JSContext * cx=0x02888db8)  Line 923 + 0x671 bytes	C++
 	mozjs.dll!js_Invoke(JSContext * cx=0x02888db8, unsigned int argc=1, int * vp=0x059c43f8, unsigned int flags=0)  Line 1396 + 0x9 bytes	C++
 	xul.dll!nsXPCWrappedJSClass::CallMethod(nsXPCWrappedJS * wrapper=0x05849ea8, unsigned short methodIndex=3, const XPTMethodDescriptor * info=0x038634b8, nsXPTCMiniVariant * nativeParams=0x0018ccf4)  Line 1696 + 0x1b bytes	C++
 	xul.dll!nsXPCWrappedJS::CallMethod(unsigned short methodIndex=3, const XPTMethodDescriptor * info=0x038634b8, nsXPTCMiniVariant * params=0x0018ccf4)  Line 571	C++
 	xul.dll!PrepareAndDispatch(nsXPTCStubBase * self=0x08bb3b60, unsigned int methodIndex=3, unsigned int * args=0x0018cdb4, unsigned int * stackBytesToPop=0x0018cda4)  Line 114 + 0x21 bytes	C++
 	xul.dll!SharedStub()  Line 142	C++
 	xul.dll!nsEventListenerManager::HandleEventSubType(nsListenerStruct * aListenerStruct=0x08ba9670, nsIDOMEventListener * aListener=0x08bb3b60, nsIDOMEvent * aDOMEvent=0x03d8c190, nsPIDOMEventTarget * aCurrentTarget=0x056e36b0, unsigned int aPhaseFlags=2, nsCxPusher * aPusher=0x0018d0e4)  Line 1056 + 0x12 bytes	C++
 	xul.dll!nsEventListenerManager::HandleEvent(nsPresContext * aPresContext=0x085958b0, nsEvent * aEvent=0x03ef00b0, nsIDOMEvent * * aDOMEvent=0x0018d0d4, nsPIDOMEventTarget * aCurrentTarget=0x056e36b0, unsigned int aFlags=2, nsEventStatus * aEventStatus=0x0018d0d8, nsCxPusher * aPusher=0x0018d0e4)  Line 1174	C++
 	xul.dll!nsEventTargetChainItem::HandleEvent(nsEventChainPostVisitor & aVisitor={...}, unsigned int aFlags=2, int aMayHaveNewListenerManagers=0, nsCxPusher * aPusher=0x0018d0e4)  Line 202	C++
 	xul.dll!nsEventTargetChainItem::HandleEventTargetChain(nsEventChainPostVisitor & aVisitor={...}, unsigned int aFlags=6, nsDispatchingCallback * aCallback=0x00000000, int aMayHaveNewListenerManagers=0, nsCxPusher * aPusher=0x0018d0e4)  Line 351	C++
 	xul.dll!nsEventDispatcher::Dispatch(nsISupports * aTarget=0x05fd816c, nsPresContext * aPresContext=0x085958b0, nsEvent * aEvent=0x03ef00b0, nsIDOMEvent * aDOMEvent=0x03d8c190, nsEventStatus * aEventStatus=0x00000000, nsDispatchingCallback * aCallback=0x00000000, nsCOMArray<nsPIDOMEventTarget> * aTargets=0x00000000)  Line 601 + 0x1e bytes	C++
 	xul.dll!nsEventDispatcher::DispatchDOMEvent(nsISupports * aTarget=0x05fd816c, nsEvent * aEvent=0x00000000, nsIDOMEvent * aDOMEvent=0x03d8c190, nsPresContext * aPresContext=0x085958b0, nsEventStatus * aEventStatus=0x00000000)  Line 664 + 0x1d bytes	C++
 	xul.dll!nsPresContext::FireDOMPaintEvent()  Line 2043 + 0x1f bytes	C++
 	xul.dll!nsRunnableMethod<nsPresContext,void>::Run()  Line 283	C++
 	xul.dll!nsThread::ProcessNextEvent(int mayWait=0, int * result=0x0018d274)  Line 527 + 0x19 bytes	C++
 	xul.dll!NS_ProcessNextEvent_P(nsIThread * thread=0x0098be98, int mayWait=0)  Line 250 + 0x16 bytes	C++
 	xul.dll!mozilla::ipc::MessagePump::Run(base::MessagePump::Delegate * aDelegate=0x0098b8f0)  Line 118 + 0xe bytes	C++
 	xul.dll!MessageLoop::RunInternal()  Line 212	C++
 	xul.dll!MessageLoop::RunHandler()  Line 195	C++
 	xul.dll!MessageLoop::Run()  Line 169	C++
 	xul.dll!nsBaseAppShell::Run()  Line 180	C++
 	xul.dll!nsAppShell::Run()  Line 240	C++
 	xul.dll!nsAppStartup::Run()  Line 183 + 0x1c bytes	C++
 	xul.dll!XRE_main(int argc=4, char * * argv=0x0068d9e8, const nsXREAppData * aAppData=0x00982010)  Line 3476 + 0x25 bytes	C++
 	firefox.exe!NS_internal_main(int argc=4, char * * argv=0x0068d9e8)  Line 158 + 0x12 bytes	C++
 	firefox.exe!wmain(int argc=4, wchar_t * * argv=0x0068f780)  Line 120 + 0xd bytes	C++
 	firefox.exe!__tmainCRTStartup()  Line 583 + 0x19 bytes	C
 	firefox.exe!wmainCRTStartup()  Line 403	C
 	kernel32.dll!772f1174() 	
 	ntdll.dll!774ab3f5() 	
 	ntdll.dll!774ab3c8()
Reproduced 3/3 times by navigating to http://technet.microsoft.com/en-us/sysinternals/default.aspx, one time by next navigating to the "Process Explorer" page.  Seeing if this happens on other sites as well.
Epic bugzilla search fail on my part ...
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 543839
You need to log in before you can comment on or make changes to this bug.