add an android builder to buildbot

VERIFIED FIXED

Status

Tamarin
Build Config
VERIFIED FIXED
8 years ago
8 years ago

People

(Reporter: Dan Schaffer, Assigned: Dan Schaffer)

Tracking

Details

Attachments

(4 attachments, 1 obsolete attachment)

(Assignee)

Description

8 years ago
we'll add a mac compiling the android shell first.  android platform build support was submitted in bug 543512.
(Assignee)

Comment 1

8 years ago
Created attachment 424994 [details] [diff] [review]
android compile buildbot patch
Assignee: nobody → dschaffe
Status: NEW → ASSIGNED
Attachment #424994 - Flags: review?(brbaker)
(Assignee)

Comment 2

8 years ago
Created attachment 425079 [details] [diff] [review]
updated android buildbot patch

updated patch after testing on local buildbot.  also added base smoke and test phases for android.
Attachment #424994 - Attachment is obsolete: true
Attachment #425079 - Flags: review?(brbaker)
Attachment #424994 - Flags: review?(brbaker)

Comment 3

8 years ago
Comment on attachment 425079 [details] [diff] [review]
updated android buildbot patch

Pushed buildbot configuration, with a bunch of tweaks as TR changeset 3740:3a3915d9fc4e

Pushed buildslave scripts as:
TR-argo: 3658:326014d14403
TR: 3738:326014d14403
Attachment #425079 - Flags: review?(brbaker) → review+

Updated

8 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Assignee)

Comment 4

8 years ago
marking verified.  buildbot mostly worked.
Status: RESOLVED → VERIFIED
(Assignee)

Updated

8 years ago
Duplicate of this bug: 531913
(Assignee)

Comment 6

8 years ago
Created attachment 428806 [details] [diff] [review]
patch

patch to add smoke and test phase for android
Attachment #428806 - Flags: review?(brbaker)

Comment 7

8 years ago
Comment on attachment 428806 [details] [diff] [review]
patch

r+ with comments addressed

caveat: I did not try and run the scripts as I am not setup to run them

- should workdir="../repo/build/buildbot/slaves/scripts"? 
- please rename the /AcceptanceTest/ buildsteps to match the others /Testsuite_Release/
- in run-acceptancetests-android.sh (and in smoke script) you test for SHELLSERVER and print an error if it is not set but then continue with the script
Attachment #428806 - Flags: review?(brbaker) → review+

Comment 8

8 years ago
Comment on attachment 428806 [details] [diff] [review]
patch

- Also change the /BuildShellCommand/ to /TestSuiteShellCommand/
(Assignee)

Comment 9

8 years ago
pushed 3909:42c3e240b197
(Assignee)

Comment 10

8 years ago
Created attachment 429529 [details] [diff] [review]
actual patch

Comment 11

8 years ago
Changed the smokes buildstep for android to be TestSuiteShellCommand
tamarin-redux - changeset - 3948:d2502cc1b180
(Assignee)

Comment 12

8 years ago
Created attachment 436700 [details] [diff] [review]
patch for build-release-android-shell.sh
Attachment #436700 - Flags: review?(brbaker)
(Assignee)

Comment 13

8 years ago
above patch fixes problem where release build errors are not marked as failures

Comment 14

8 years ago
Comment on attachment 436700 [details] [diff] [review]
patch for build-release-android-shell.sh

patch does not apply cleanly. needs to be rebased, but otherwise it is a r+
Attachment #436700 - Flags: review?(brbaker) → review-
You need to log in before you can comment on or make changes to this bug.