Repaint issue in Vanilla Forums, when clicking "Preview Post"

RESOLVED FIXED

Status

()

RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: dholbert, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
STEPS TO REPRODUCE:
1. Load a Vanilla Forums discussion, e.g. on Mozilla's intranet instance at
    https://intranet.mozilla.org/forum/comments.php?DiscussionID=902
2. Type a few lines of text in the comment field
     (e.g. 'a b c d' each on its own line)
3. Click "Preview Post"

ACTUAL RESULTS:
The contents of your "Preview" comment don't get painted. Instead, you get a duplicate of the chunk of page that was pushed downards to make room for the preview.  (If you click the window titlebar, or click in a different window, then it repaints correctly.)

WORKS:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.3a1pre) Gecko/20100109 Minefield/3.7a1pre
Built from http://hg.mozilla.org/mozilla-central/rev/6a7294d0f305

BROKEN:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.3a1pre) Gecko/20100112 Minefield/3.7a1pre
Built from http://hg.mozilla.org/mozilla-central/rev/a43e2f7eda8f

Regression Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=6a7294d0f305&tochange=a43e2f7eda8f

Looks like a regression from bug 526394.
(Reporter)

Comment 1

9 years ago
Created attachment 425052 [details]
screenshot of bug
(Reporter)

Comment 2

9 years ago
This persists up through today's m-c nightly, btw:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.3a1pre) Gecko/20100203 Minefield/3.7a1pre
Should be fixed by landing of bug 543681.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Depends on: 543681
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.