Tab bar disappears with two tabs open

RESOLVED WORKSFORME

Status

()

Firefox
Tabbed Browser
RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: Alex Foote, Unassigned)

Tracking

3.6 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-GB; rv:1.9.2) Gecko/20100115 Firefox/3.6
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-GB; rv:1.9.2) Gecko/20100115 Firefox/3.6

With three tabs open, deleting the third tab causes the tab bar to disappear and the window only shows tab 2. Opening another tab causes the tab bar to re-appear showing the three tabs.
In preferences, "always show the tab bar" is unchecked.

Reproducible: Sometimes

Steps to Reproduce:
1. Open three tabs
2. Close tab no.3.
Actual Results:  
Tab bar disappears and the window shows the contents of tab 2.

Expected Results:  
Tab bar should remain, showing the two remaining tabs.
(Reporter)

Comment 1

8 years ago
On further check, closing tab 1 or 3 leaves tab 2 in focus ; closing tab 2 leaves tab 1 in focus.
This works fine for me at least on Windows Vista.
Is this reproducible in safe-mode / with a new profile?
http://support.mozilla.com/en-US/kb/Troubleshooting+extensions+and+themes
http://support.mozilla.com/en-US/kb/Basic+Troubleshooting#Make_a_new_profile
Version: unspecified → 3.6 Branch
(Reporter)

Comment 3

8 years ago
It's very intermittent - has perhaps happened 3 times over as many weeks.

With the issue, I opened a second window - the second window did not have the same error. I closed this window.

I closed firefox (setting preferences to "When Firefox starts, show windows and tabs from last time") and opened it again, and the window no longer had the issue.

I'll keep looking for anything that seems to reliably trigger the error, so I can test with a clean profile and/or safe mode.
Duplicate of this bug: 544457

Comment 5

8 years ago
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2.2) Gecko/20100316 Firefox/3.6.2
Reporter, Please update if you are still reproduce in safe mode / new profile.
Whiteboard: [closeme 2010-03-31]
(Reporter)

Comment 6

8 years ago
Even without having changed profile, I haven't seen this bug again since my last comment and so haven't been able to test further.

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
Whiteboard: [closeme 2010-03-31]
You need to log in before you can comment on or make changes to this bug.