Top rated addons list in category pages are not

VERIFIED FIXED in 5.7

Status

P3
normal
VERIFIED FIXED
9 years ago
3 years ago

People

(Reporter: yhspock-amo, Unassigned)

Tracking

unspecified

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7 (.NET CLR 3.5.30729)
Build Identifier: 5.6

Since the launch of AMO 5.6, the top rated addons in the category pages seem way off:
* The lists are completely different from what they looked like before the upgrade. 
* The lists are completely different from what you see when you click the "view all top rated" on the bottom of the list
* Some addons in the top rated list aren't even rated at all, others have 4 stars, etc. Just doesn't make sense.

Reproducible: Always

Steps to Reproduce:
1. Go to a category page, say, Feeds, News & Blogging
2. Look at the top rated list, there are addons that aren't even rated
3. Click the "view all top rated" on the bottom of the list
4. You'll see a completely different (and more logical) list.


Expected Results:  
The top rated list in the category pages should be sorted by bayesian rating, just like the search results and "view all top rated" lists.

Comment 1

9 years ago
Clearly broken. List star ratings in order are currently shown as: 5, 4, 0, 5, 5, 5, 5, 5, 0, 3.

Looks like bug 539604 but for the category landing pages, this time. Clicking "View all top rated »" seems to get it right.
Status: UNCONFIRMED → NEW
Depends on: 539604
Ever confirmed: true
OS: Windows XP → All
Hardware: x86 → All

Comment 2

9 years ago
This list is labeled "Top rated", but is sorted by last update date. The addons shown are the ten most recently updated.

It should be sorted by "averagerating".

Comment 3

9 years ago
Created attachment 425463 [details] [diff] [review]
Patch to sort by rating

It would be a good idea to also change the variables names (updated_addons, upd_addons) in the controller and the view to match their real use : toprated_addons
Severity: major → normal
Priority: -- → P3
Target Milestone: --- → 5.7
Attachment #425463 - Flags: review?(clouserw)
Comment on attachment 425463 [details] [diff] [review]
Patch to sort by rating

I assume this is ready for review...
Attachment #425463 - Flags: review?(clouserw) → review?(dd)
Fixed in r61915.  Thanks for the patch and suggestions.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED

Comment 6

9 years ago
STR:
1.Go to https://preview.addons.mozilla.org/en-US/firefox/browse/type:1/cat:72
2.Notice the top rated addons section
3.The addon-"Fastest Firefox" has 5 star rating from 133 reviews.
4.The addon-"PrayTimes" has 5 star rating from 168 reviews.

expected result:
Praytimes is listed above Fastest Firefox

actual result:
Fastest Firefox is listed above Praytimes.

Dave suggested that this might be a problem with bayesian rating.Is this something we want to look into before 5.7?

Reopening for clarification.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
The average of those 168 (4.75496) is lower than the 133 (4.77689).  This is expected behavior.
Status: REOPENED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → FIXED

Comment 8

9 years ago
verified fixed on all category landing pages in Preview
Status: RESOLVED → VERIFIED
(Assignee)

Updated

3 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.