Add X-Bugzilla-Whiteboard header to emails

RESOLVED DUPLICATE of bug 803102

Status

()

Bugzilla
Email Notifications
--
enhancement
RESOLVED DUPLICATE of bug 803102
9 years ago
5 years ago

People

(Reporter: Unfocused, Assigned: sjoshi)

Tracking

Details

Attachments

(1 attachment)

Emails from b.m.o have a bunch of useful headers (X-Bugzilla-Reason, X-Bugzilla-Product, etc) - but a header for the whiteboard field is missing. Would be really useful to have that.
Assignee: nobody → email-notifications
Component: Bugzilla: Other b.m.o Issues → Email Notifications
Product: mozilla.org → Bugzilla
QA Contact: other-bmo-issues → default-qa
Version: other → 3.4.4

Updated

9 years ago
Severity: normal → enhancement
(Assignee)

Comment 1

5 years ago
Created attachment 808310 [details] [diff] [review]
Patch-v1
Assignee: email-notifications → joshi_sunil
Status: NEW → ASSIGNED
Attachment #808310 - Flags: review?(simon)

Comment 2

5 years ago
How long before we add all bug fields into headers? I don't think we should include the status whiteboard into headers. This field can be 16MB big, see bug 824701. I would say WONTFIX due to this.
I tend to agree with LpSolit here... although the information that's typically getting put in the whiteboard these days would be pretty useful to filter on.  If it gets on a header at all, it needs to be truncated to some normal length (16MB is way too big ;) ) and some heavy filtering done to screen out anything that would coke an email header.
Agree. --> WONTFIX
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
Attachment #808310 - Flags: review?(simon)
Er, multi-megabyte data in the whiteboard field is hardly the norm. The value here is getting the first 100 characters or so, since the whiteboard field is commonly used for additional metadata similar to keywords and flags. Truncating doesn't diminish the value here.
If this won't be taken in Bugzilla itself, could it be added to just BMO?
Flags: needinfo?(glob)
(In reply to Blair McBride [:Unfocused] from comment #6)
> If this won't be taken in Bugzilla itself, could it be added to just BMO?

No, bug 803102 is also WONTFIX.
Flags: needinfo?(glob)
Resolution: WONTFIX → DUPLICATE
Duplicate of bug: 803102
You need to log in before you can comment on or make changes to this bug.