running android shell on significant abc file returns failed assertion: LIR structure error

VERIFIED DUPLICATE of bug 543144

Status

VERIFIED DUPLICATE of bug 543144
9 years ago
8 years ago

People

(Reporter: dschaffe, Unassigned)

Tracking

Details

(Reporter)

Description

9 years ago
a simple abc like print("hello") works.  running any acceptance test return a failed assertion: LIR structure error.  I am using the emulator and 2010_01_25 android sdk.
setup:
(if emulator is not running)
$ emulator&
$ cd platform/android
$ make
$ make install (or adb push ./avmshell /data/app)
I'm using test/acceptance/as3/AbcDecoder/accessSpecifiers.abc any test reproduces
either do:
$ ./android_shell ~/hg/tamarin-redux/test/acceptance/as3/AbcDecoder/accessSpecifiers.abc
or equivalent is:
$ adb push ~/hg/tamarin-redux/test/acceptance/as3/AbcDecoder /data/app/avmtest.abc
$ adb shell "cd /data/app;./avmshell avmtest.abc"

output:
Assertion failed: 

  LIR structure error (writePrologue(body)):
    in instruction with opcode: callh
    argument 1 has opcode: icall
    it should be: fcall
  One way to debug this:  change the failing NanoAssertMsgf(0, ...) call to a
  printf(...) call and rerun with verbose output.  If you're lucky, this error
  message will appear before the block containing the erroneous instruction.

: 0 (../../nanojit/LIR.cpp:2339)
[1]   Trap                    ./avmshell avmte...
(Reporter)

Comment 1

9 years ago
marking as dup of 543144, the softfloat problem is occurring.  running with -Darm_vfp works (sort of)
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 543144

Comment 2

8 years ago
bulk verifying resolved !fixed issues
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.