Closed Bug 544371 Opened 12 years ago Closed 12 years ago

Build fails on FreeBSD 7.2 when creating ogglpay.o

Categories

(Firefox :: File Handling, defect)

x86
FreeBSD
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 449066

People

(Reporter: leighton, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_8; en-us) AppleWebKit/531.21.8 (KHTML, like Gecko) Version/4.0.4 Safari/531.21.10
Build Identifier: mozilla-central rev. 6d13028da120

On FreeBSD 7.2, specify --disable-ipc to avoid a FreeBSD related build problem with ipc, then do build.  The build will fail at gcc -o oggplpay.o ...

The build errors can be side stepped with --disable-ogg.



Reproducible: Always

Steps to Reproduce:
1. Download mozilla-central rev 6d13028da120 to a FreeBSD 7.2 machine
2. Add --disable-ipc to .mozconfig to avoid a FreeBSD related build issue with ipc
3. Run configure and gmake in build directory to build Firefox.
Actual Results:  
gcc -o oggplay.o -c -I../../../../dist/system_wrappers -include
../../../../../config/gcc_hidden.h -DHAVE_CONFIG_H -DOSTYPE=\"FreeBSD7\"
-DOSARCH=FreeBSD
-I../../../../../media/liboggplay/src/liboggplay/../../include/oggplay
-I../../../../../media/liboggplay/src/liboggplay -I.
-I../../../../dist/include -I../../../../dist/include/nsprpub
-I/home/leighton/development/firefox/source/sctp/src/obj-ff-dbg/dist/include/nspr
-I/home/leighton/development/firefox/source/sctp/src/obj-ff-dbg/dist/include/nss
      -fPIC -I/usr/local/include -Wall -W -Wno-unused -Wpointer-arith
-Wcast-align -W -Wno-long-long -pedantic -fno-strict-aliasing -pipe 
-DDEBUG -D_DEBUG -DDEBUG_leighton -DTRACING -g  -I/usr/local/include
-include ../../../../mozilla-config.h -DMOZILLA_CLIENT
-Wp,-MD,.deps/oggplay.pp
../../../../../media/liboggplay/src/liboggplay/oggplay.c
In file included from ../../../../dist/include/oggz/oggz_off_t.h:52,
                 from ../../../../dist/include/oggz/oggz.h:575,
                 from
../../../../dist/include/oggplay/oggplay_reader.h:45,
                 from ../../../../dist/include/oggplay/oggplay.h:51, from
../../../../../media/liboggplay/src/liboggplay/oggplay_private.h:50,
                 from
../../../../../media/liboggplay/src/liboggplay/oggplay.c:40:
../../../../dist/include/oggz/oggz_off_t_generated.h:65: error: expected
'=', ',', ';', 'asm' or '__attribute__' before 'oggz_off_t'
In file included from ../../../../dist/include/oggz/oggz.h:578,
                 from
../../../../dist/include/oggplay/oggplay_reader.h:45,
                 from ../../../../dist/include/oggplay/oggplay.h:51, from
../../../../../media/liboggplay/src/liboggplay/oggplay_private.h:50,
                 from
../../../../../media/liboggplay/src/liboggplay/oggplay.c:40:
../../../../dist/include/oggz/oggz_seek.h:134: error: expected '=', ',',
';', 'asm' or '__attribute__' before 'oggz_tell'
../../../../dist/include/oggz/oggz_seek.h:143: error: expected '=', ',',
';', 'asm' or '__attribute__' before 'oggz_seek'
../../../../dist/include/oggz/oggz_seek.h:474: error: expected declaration
specifiers or '...' before 'oggz_off_t'
In file included from
../../../../../media/liboggplay/src/liboggplay/oggplay_private.h:53,
                 from
../../../../../media/liboggplay/src/liboggplay/oggplay.c:40:
../../../../dist/include/theora/theora.h:183: warning: comma at end of
enumerator list
In file included from
../../../../../media/liboggplay/src/liboggplay/oggplay.c:40:
../../../../../media/liboggplay/src/liboggplay/oggplay_private.h:78:1:
warning: C++ style comments are not allowed in ISO C90
../../../../../media/liboggplay/src/liboggplay/oggplay_private.h:78:1:
warning: (this will be reported only once per input file)
In file included from
../../../../../media/liboggplay/src/liboggplay/oggplay.c:40:
../../../../../media/liboggplay/src/liboggplay/oggplay_private.h: In
function 'oggplay_check_add_overflow':
../../../../../media/liboggplay/src/liboggplay/oggplay_private.h:325:
warning: comparison of unsigned expression >= 0 is always true
../../../../../media/liboggplay/src/liboggplay/oggplay_private.h:326:
warning: comparison of unsigned expression >= 0 is always true
../../../../../media/liboggplay/src/liboggplay/oggplay.c: In function
'oggplay_get_available':
../../../../../media/liboggplay/src/liboggplay/oggplay.c:921: warning:
implicit declaration of function 'oggz_tell'
gmake[5]: *** [oggplay.o] Error 1
gmake[5]: Leaving directory
`/home/leighton/development/firefox/source/sctp/src/obj-ff-dbg/media/liboggplay/src/liboggplay'
gmake[4]: *** [libs] Error 2
gmake[4]: Leaving directory
`/home/leighton/development/firefox/source/sctp/src/obj-ff-dbg/media/liboggplay/src'
gmake[3]: *** [libs] Error 2
gmake[3]: Leaving directory
`/home/leighton/development/firefox/source/sctp/src/obj-ff-dbg/media/liboggplay'
gmake[2]: *** [libs_tier_gecko] Error 2
gmake[2]: Leaving directory
`/home/leighton/development/firefox/source/sctp/src/obj-ff-dbg'
gmake[1]: *** [tier_gecko] Error 2
gmake[1]: Leaving directory
`/home/leighton/development/firefox/source/sctp/src/obj-ff-dbg'
gmake: *** [default] Error 2
[leighton@chablis ~/development/firefox/source/sctp/src/obj-ff-dbg]$

Expected Results:  
successful build
OS: Other → FreeBSD
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 449066
You need to log in before you can comment on or make changes to this bug.