typed array construction aborts tracing

RESOLVED DUPLICATE of bug 557728

Status

()

Core
JavaScript Engine
RESOLVED DUPLICATE of bug 557728
8 years ago
8 years ago

People

(Reporter: vlad, Assigned: vlad)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Created attachment 425340 [details] [diff] [review]
constructor tracing fix

Some of the typed array construction forms were using JS_ConstructObject to create the internal ArrayBuffer, which would end up needlessly aborting tracing with a deep abort.  This fixes that problem by just constructing the object directly.
Attachment #425340 - Flags: review?(jorendorff)
Attachment #425340 - Flags: review?(jorendorff) → review+
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 557728
You need to log in before you can comment on or make changes to this bug.