If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

investigate try talos wait times

RESOLVED FIXED

Status

Release Engineering
General
RESOLVED FIXED
8 years ago
4 years ago

People

(Reporter: aki, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
Wait time report for try talos for jobs submitted since Wed Feb  3 00:00:02 2010
>
> tiger
>   0 ######################################################################################################### (105)
>  15 ## (2)
>  30 # (1)
>  45 ############## (14)
>  60 ###### (6)
>  75  (0)
>  90 ######### (9)
>  105 # (1)
>  120 #### (4)
>  135 #### (4)

Tiger Talos waits have been bad a bunch lately -- is there a bug I
should follow to track when that'll be better?

> > xp
> >   0 ################################################## (50)
> >  15 ########## (10)
> >  30 ##################### (21)
> >  45 ################### (19)
> >  60 ############ (12)
> >  75 ############ (12)
> >  90 ########### (11)
> >  105 ######## (8)
> >  120 ############## (14)
> >  135 ########### (11)
> >  150 ## (2)

Also strange that XP is so much more backlogged than Vista -- are we a
lot slower on XP?
(Reporter)

Comment 1

8 years ago
(Alice, correct me if I'm wrong...)

As far as Tiger is concerned:  Tiger won't run trunk builds (as designed).
Try can run builds from multiple branches, so we have a couple of Tiger talos boxes for those pushes that are based on pre-10.5 sdk code.

Aiui the Tiger Try factories actually check to see if the build can run on Tiger, and exit if they aren't.  So, as largely no-op processes, we only have a couple of Tiger slaves connected.

If this is an issue (a large number of incoming/future Try patches based on pre-10.5 code) then we may need to pad the number of Tiger Try Talos slaves; otherwise this hopefully isn't an issue.

Still owe you an answer on XP, however.
(Reporter)

Comment 2

8 years ago
As far as XP vs Vista:  [afaict] we have 11 Vista boxes and 10 XP boxes allocated to Talos Try.

However, there are 10 Vista boxes currently connected and 5 XP, which would explain the difference in responsiveness.

I'll try to track down why the disconnected boxes are down and if they're missing nagios coverage.
(Reporter)

Comment 3

8 years ago
Filed bug 545229 to verify nagios setup.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Assignee)

Updated

4 years ago
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.