Last Comment Bug 544508 - install buttons
: install buttons
Status: RESOLVED FIXED
[z]
:
Product: addons.mozilla.org Graveyard
Classification: Graveyard
Component: Public Pages (show other bugs)
: 4.x
: All All
: P1 normal
: 5.8
Assigned To: Jeff Balogh (:jbalogh)
:
:
Mentors:
https://preview.addons.mozilla.org/z/...
: 491446 (view as bug list)
Depends on: 546829 552738
Blocks: 504481 516710 521556 539301 548121 548129 551682 552465 565136
  Show dependency treegraph
 
Reported: 2010-02-05 10:12 PST by Jeff Balogh (:jbalogh)
Modified: 2016-02-04 14:51 PST (History)
10 users (show)
krupa.mozbugs: in‑litmus+
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
a few buttons, v1 (95.80 KB, image/png)
2010-02-08 13:53 PST, Justin Scott [:fligtar]
no flags Details
buttons, v2 (200.81 KB, image/png)
2010-02-09 13:40 PST, Justin Scott [:fligtar]
no flags Details
buttons, v3 (333.49 KB, image/png)
2010-02-11 11:26 PST, Justin Scott [:fligtar]
no flags Details
button matrix, v4 (369.01 KB, image/png)
2010-02-15 15:03 PST, Justin Scott [:fligtar]
no flags Details
button states, v1 (29.97 KB, image/png)
2010-02-15 15:03 PST, Justin Scott [:fligtar]
no flags Details
button matrix, v5 (389.68 KB, image/png)
2010-02-17 09:47 PST, Justin Scott [:fligtar]
no flags Details
button states, v2 (31.61 KB, image/png)
2010-02-17 09:47 PST, Justin Scott [:fligtar]
no flags Details
incompatible details page mockup (80.68 KB, image/png)
2010-02-17 09:47 PST, Justin Scott [:fligtar]
no flags Details
many button states in action (507.47 KB, image/png)
2010-02-17 09:48 PST, Justin Scott [:fligtar]
no flags Details

Description Jeff Balogh (:jbalogh) 2010-02-05 10:12:26 PST
:(
Comment 1 Justin Scott [:fligtar] 2010-02-08 13:51:50 PST
After talking with Clearleft about a number of the changes we want to make, they thought it would be best to take a look at redoing our install buttons across the board so that they can all be consistent.

We'll need some install buttons for 5.7 for the user profile pages, but those can either be normal links or the existing buttons, since the new buttons are mostly similar for public add-ons.

But by the end of this week we should have all of the new designs for all of the cases in the massive flowchart.
Comment 2 Justin Scott [:fligtar] 2010-02-08 13:53:39 PST
Created attachment 425855 [details]
a few buttons, v1

Here's the direction they're going. There are a few issues that I pointed out to them and a bunch of missing cases, but just wanted to give a preview.
Comment 3 Jorge Villalobos [:jorgev] 2010-02-08 14:22:02 PST
A couple of notes:

1) I think the buttons for listed add-ons should visually be more similar (or event equal) to the sandboxed add-on buttons, and not the same as public add-on buttons. I like the striped pattern. Maybe with a different color?

2) I think the warning should be more verbose. It should say something like "Unreviewed add-ons can read and change your preferences, access your passwords, send your information to third parties, install other software in your computer, ...". I would also add a link to the bottom of the bubble that expands on this.
Comment 4 Justin Scott [:fligtar] 2010-02-09 13:40:17 PST
Created attachment 426064 [details]
buttons, v2

Some additional button states.

Next he'll be adding the larger button versions for the listing pages and the JS-disabled states.

I also asked for some iconography in the pop-ups so that they don't turn into "whatever" buttons, especially for unreviewed add-ons.
Comment 5 Justin Scott [:fligtar] 2010-02-10 20:38:07 PST
After trying to figure out how to handle the JS-disabled case for these pop-ups, Clearleft wants to know if it would be okay to have an interstitial page that the buttons link to where the message would be displayed and then users would either accept the message or cancel and go back.

I'm fine with this. People with JS disabled have chosen to lead hard lives on the web, and we're still providing the same functionality for them to download their add-on.

Note that if JS is disabled we can't do most of these compatibility checks anyway, so the only dialogs this would apply to are self-hosted and unreviewed add-ons, which are important dialogs.

I'm going to tell them that proceeding with this method is fine, but if anyone has serious objections to this, please let me know.
Comment 6 Justin Scott [:fligtar] 2010-02-11 11:26:06 PST
Created attachment 426541 [details]
buttons, v3
Comment 7 Justin Scott [:fligtar] 2010-02-15 15:03:05 PST
Created attachment 427015 [details]
button matrix, v4
Comment 8 Justin Scott [:fligtar] 2010-02-15 15:03:30 PST
Created attachment 427016 [details]
button states, v1
Comment 9 Dave Garrett 2010-02-15 16:59:35 PST
*** Bug 491446 has been marked as a duplicate of this bug. ***
Comment 10 Justin Scott [:fligtar] 2010-02-17 09:47:00 PST
Created attachment 427358 [details]
button matrix, v5
Comment 11 Justin Scott [:fligtar] 2010-02-17 09:47:19 PST
Created attachment 427359 [details]
button states, v2
Comment 12 Justin Scott [:fligtar] 2010-02-17 09:47:53 PST
Created attachment 427360 [details]
incompatible details page mockup
Comment 13 Justin Scott [:fligtar] 2010-02-17 09:48:20 PST
Created attachment 427361 [details]
many button states in action
Comment 14 Dave Garrett 2010-02-17 10:06:38 PST
A concern with the "install anyway" button I have is that users may not be aware that Firefox won't let them do that without overriding its compatibility checking. You may wish to link to a help page about this issue from the popup bubble so that users don't get confused why it won't actually install.
Comment 15 Justin Scott [:fligtar] 2010-02-23 15:36:26 PST
This is waiting on Craig's implementation in bug 546829
Comment 16 Jeff Balogh (:jbalogh) 2010-03-16 19:40:35 PDT
Questions about the button matrix: 
1. The text for "Other browsers" in row 1 is Firefox-specific.  What do we show when we're looking at thunderbird add-ons a) in Firefox b) in Thunderbird?
2. If I'm in Firefox looking at /thunderbird, all the buttons are going to be concealed.  Is this really what we want?
3. Are we really going to maintain what the current version of Firefox is, and where you can download a nightly?
4. Do all the Firefox buttons point at http://mozilla.com?  Where do those buttons point for other browsers?
5. How much do we care about the interstitial pages for non-js?  All the download URLs will have to come out of the server pointing to something other than an xpi.  Then js will have to munge all those URLs.  It's not impossible, just annoying, and complicates everyone's life for users we don't care that much about.  Can we assume that non-js users deserve whatever comes down to them?  They're probably not scared by our warnings anyways.

# Glossary

concealed: dimmed text, white background
Comment 17 Jeff Balogh (:jbalogh) 2010-03-16 19:50:38 PDT
6. How do these interact? a) Wrong platform + old/new version b) Unreviewed + either part of (a) c) unreviewed + eula d) any combination I'm missing
Comment 18 Fred Wenzel [:wenzel] 2010-03-17 00:19:12 PDT
(In reply to comment #16)
> Can we assume that non-js users deserve whatever comes down to
> them?  They're probably not scared by our warnings anyways.

I don't know how many different warnings there are, but maybe a one-sentence noscript for each of these warnings (containing a useful link, to either the FAQ or getfirefox.com or something) will suffice?
Comment 19 Justin Scott [:fligtar] 2010-03-17 08:48:40 PDT
(In reply to comment #16)
> Questions about the button matrix: 
> 1. The text for "Other browsers" in row 1 is Firefox-specific.  What do we show
> when we're looking at thunderbird add-ons a) in Firefox b) in Thunderbird?
The "other browser" pitch/warning only shows up for Firefox. If you're browsing /seamonkey we don't tell you to get SeaMonkey, and if you're browsing in /thunderbird we can't tell if the person doesn't have Thunderbird.

> 2. If I'm in Firefox looking at /thunderbird, all the buttons are going to be
> concealed.  Is this really what we want?
Why are they all concealed? They should all be active and say "Download Now" unless it's not compatible with their OS. If the user is browsing in a Thunderbird user agent, they can act just like Firefox does and say Add to Thunderbird and show when incompatible with that TB version. 

> 3. Are we really going to maintain what the current version of Firefox is, and
> where you can download a nightly?
I don't think we maintain the current version in order to achieve this functionality. Please look at what we do currently. I'll post the URL to link to later -- we'd only link to alpha/beta releases, not nightlies.

> 4. Do all the Firefox buttons point at http://mozilla.com?  Where do those
> buttons point for other browsers?
Firefox buttons point to getfirefox.com?src=amo. There are no other browsers to point to.

> 5. How much do we care about the interstitial pages for non-js?  All the
> download URLs will have to come out of the server pointing to something other
> than an xpi.  Then js will have to munge all those URLs.  It's not impossible,
> just annoying, and complicates everyone's life for users we don't care that
> much about.  Can we assume that non-js users deserve whatever comes down to
> them?  They're probably not scared by our warnings anyways.
Can you show me what you propose the original page would look like without JS for an unreviewed add-on?
Comment 20 Justin Scott [:fligtar] 2010-03-17 08:56:05 PDT
(In reply to comment #17)
> 6. How do these interact? a) Wrong platform + old/new version b) Unreviewed +
> either part of (a) c) unreviewed + eula d) any combination I'm missing

a) the popup should have both the incompatible text and icon and the old/new version text and icon. the buttons should be whatever they would be based on the old/new text.

b) pop up experimental warning first. if they click the button there, then popup whatever additional warnings need to be shown.

c) there's a mockup of featured + eula, so just swap out featured with unreviewed. we'll get the full click through when they have to accept the eula (the "Accept and Install" button should be the unreviewed button and popup)
Comment 21 Jeff Balogh (:jbalogh) 2010-03-17 11:18:36 PDT
(In reply to comment #19)
> Can you show me what you propose the original page would look like without JS
> for an unreviewed add-on?

http://img.skitch.com/20100317-tk25u8cc6s5rhaa8jcirufhbwf.png
Comment 22 Justin Scott [:fligtar] 2010-03-17 19:40:02 PDT
We need to display the warning even for JS disablers. It can be in an interstitial page or it can link to the details page and the details page can have the warning expanded and they don't have to click through it.
Comment 23 Jeff Balogh (:jbalogh) 2010-03-19 15:00:53 PDT
Started here: http://github.com/jbalogh/zamboni/commit/fda5ce40
Finished here: http://github.com/jbalogh/zamboni/commit/24a7a7ae

Note You need to log in before you can comment on or make changes to this bug.