Cannot print from lighting. cannot print from sunbird either. all other programs print fine

RESOLVED DUPLICATE of bug 351581

Status

--
major
RESOLVED DUPLICATE of bug 351581
9 years ago
8 years ago

People

(Reporter: drbrake2, Unassigned)

Tracking

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6
Build Identifier: Lightning/1.0b1 Thunderbird/3.0.1

Eveer since I loaded TB 3.0 and the newest version of Lightning I cannot print my calendar at all.  no matter what I try when I hit the print button nothing happens. ther is nothing sent to the printer.

Reproducible: Always

Steps to Reproduce:
1.Open calendar view 
2.select print
3.nothing happens



Shouldprint clendar like it did in TB 2.0 and previous lightning.
Does a second attempt at printing work? (i.e bug 351581)

Please enable calendar.debug.log and calendar.debug.log.verbose in the advanced config editor (Options > Advanced > General > Config Editor) and check your error console for messages.
(Reporter)

Comment 2

9 years ago
I can't find anything in the options menu about calender.debug.log etc???
????
With Options, I mean the application options (i.e Tools > Options, or Edit > Preferences)

Then navigate to the "Advanced" Tab at the very top with the icon

Then go to the "General" tab, the smaller gray tabs in the middle

Then you can click on Config Editor.

Comment 4

9 years ago
I'm using the same configuration :
Lightning/1.0b1 Thunderbird/3.0.3 on Windows 7 (x86_64)
Printing works fine ... on the second attempt, like described in Bug 351581

Comment 5

8 years ago
Fellow Geeks, I can confirm this bug. Please change status to CONFIRMED & assign it to someone. 

For at least two years I have been unable to print the monthly grid view of the calendar in Lightning for Thunderbird, on two different computers (but the same printer). I think I reported it two years ago, but you guys closed it saying it was not reproduceable. Well I can reproduce the problem every time. 

I am printing to a locally-attached HP Laserjet 4L. All Windows applications are able to print to this printer. Its the most standard HP PCL5e printer you could ask for. 

Thunderbird can print messages & the list view of the Lightning calendar data. It is not able to print the grid/monthly calendar view.

I'm using Mozilla Thunderbird (3.1.4, now downloading 3.1.7), Lightning (1.0b2), Provider for Google Calendar (0.7.1), & now FG Printers (0.5.0). I added FG Printers in an attempt to solve this problem, but it did not resolve the issue; FG Printers can also print its own list view of the calendar but neither its version of the monthly view nor the built-in Lightning version of the monthly view will print. The document never spools into Windows XP's print subsystem & does not show up when I view printer jobs. 

This has been a problem on two different computers, both running Windows XP Pro Corp VLK with SP3 & all current patches. 

I appreciate any help people can provide. I'd be interested in doing any testing needed for developers to fix this, if more information is needed. I did tech support for 7 years, & I'm good at following instructions. 

~Keila

Comment 6

8 years ago
Additionally, this person confirms the problem:

http://forums.mozillazine.org/viewtopic.php?f=46&t=1188285&p=6210865&hilit=monthly+print#p6210865

[quote="asaivan"]I've run into this problem on a couple of occasions, and I'm bummed.

When I import a calendar into Lightning (v .9) I cannot then turn it around and print it in the Monthly Grid View.  It will print a List View, but not Monthly Grid.  This...really...sucks.  It will not show ANYTHING in the Monthly Grid print preview, not will it print anything.  It will show for Events I have put in there, and on calendars which are local, but not any remote or imported calendars.

Is there any work around for this?[/quote]

Comment 7

8 years ago
I can't reproduce this. For me printing the Monthly Grid View works fine with WinXp SP3 Tb 3.1.7 Lightning 1.0b2.

Keila, maybe it's not your case but, could you please provide an explicit answer to both questions in comment #1 (in particular the second question)?
(Reporter)

Comment 8

8 years ago
OK  I can print the weekly grid and the monthly grid but to get it to work I have  to do it twice!

Hit print in TB, pick view, hit print,  hit print when printer dialog box opens.
nothing happens.  repeat these steps a second time without doing anything else and the calendar prints OK

I am running Windows 7 64 bit, firefox 3.6.13,lightlning 1.0b2, TB 3.1.7

Comment 9

8 years ago
well don't I feel lame . . . . . . I thought I tried this already, but indeed, if I print the same thing twice it does print the second time!!!   ***nevermind***    lol @ myself
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 351581
(In reply to comment #9)
> well don't I feel lame . . . . . . I thought I tried this already, but indeed,
> if I print the same thing twice it does print the second time!!!  
> ***nevermind***    lol @ myself

Don't worry, its our bug and its not really good user experience that you have to print twice ;-)
You need to log in before you can comment on or make changes to this bug.