Faults when 'Automatically start FF in a Private session' Option in Tools/Privacy is selected

RESOLVED INVALID

Status

()

Firefox
Private Browsing
RESOLVED INVALID
8 years ago
8 years ago

People

(Reporter: graham, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9.2) Gecko/20100115 Firefox/3.6 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9.2) Gecko/20100115 Firefox/3.6 (.NET CLR 3.5.30729)

When 'Automatically start FF in a Private session' Option in Tools/Privacy is selected
Browser header does not dislay '- Private Browse' message
In the Tools menu :-
The 'Sart / Stop Private Browsing' and 'Clear History' controls are 'greyed' inoperative.  
The 'Sart / Stop Private Browsing' displays as 'Stop Private Browsing'

Windows Vista Home Premium fully undated

Reproducible: Always

Steps to Reproduce:
1.Select 'Auto Start in Private' option, in Tools / Privacy
2. Close Firefox
3. Start Firefox
Actual Results:  
No 'Private Browsing' message in Header is shown
The Controlsin Tools for 'Start / Stop Private Browsing' and 'Clear History' and 'greyed out' and do not operate.

Expected Results:  
Header message should show correct status
The controls in Tools menu should remain active
Component: General → Private Browsing
QA Contact: general → private.browsing

Comment 1

8 years ago
This is intentional, since that mode is not a temporary status, and we don't want to constantly nag the user about an option that they have explicitly chosen to turn on.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.