Closed Bug 544630 Opened 14 years ago Closed 14 years ago

[OOPP] Dragging doesn't work in doll manipulator app (and some other problems)

Categories

(Core Graveyard :: Plug-ins, defect)

x86
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: matt, Unassigned)

References

()

Details

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.3a1pre) Gecko/20100204 Minefield/3.7a1pre ID:20100204030730

When loading the given Flash app, click-and-dragging the doll/character should do two different things: move it around if you clicked the lower half, and rotate it if you clicked the upper half.  However, with OOPP on, dragging it does nothing.  Also, the first time you click it it's head plus the name "Meiling" will appear on the bottom, and any subsequent clicks on the doll will bring up a modification menu, but you should only get that menu by double clicking on the doll.

Another problem:

1) Click on the doll to get the "head + Meiling" thing on bottom.

2) Click on "Meiling".

3) Select "Change parts".

4) Select any of the parts to change.

5) At the far right will be a scrollable list of things to select, but you can't get the scroll bar to work.
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.3a1pre) Gecko/20100205 Minefield/3.7a1pre

The dragging works fine (both actions) and also the scrollbar works fine.
Tested with Shockwave Flash 10.1 d51 with IPC enabled. 
Linux-only bug?
Same symptoms with x86_64 Linux, a0d63d34b3ae, Shockwave Flash 10.0 r42.
This is a windowed plugin.
Problem is fixed as of build 20100212073535
Thanks.  Don't know what/why this is now fixed, but this report was soon after the cause of bug 544882, so maybe it was fixed by the same change too.
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → WORKSFORME
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.