Text gets painted twice

RESOLVED FIXED in 0.6.1

Status

Skywriter
Syntax Highlighting
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: Julian Viereck, Unassigned)

Tracking

unspecified
0.6.1

Details

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_2; en-US) AppleWebKit/532.5 (KHTML, like Gecko) Chrome/4.0.249.49 Safari/532.5
Build Identifier: 

If you scroll to the right in Bespin you will see the beginning of the line painted over the current line text. This only happens for the first few lines.

Reproducible: Always
(Reporter)

Comment 1

8 years ago
Created attachment 425653 [details]
Screenshot of the bug.
(Reporter)

Comment 2

8 years ago
Created attachment 426992 [details] [diff] [review]
Fix fo the bug.
(Reporter)

Updated

8 years ago
Attachment #426992 - Attachment is patch: true
Attachment #426992 - Attachment mime type: application/octet-stream → text/plain
(Reporter)

Comment 3

8 years ago
As Patrick rewrote some code, this bug is fixed now.

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → 0.6.1
(Reporter)

Comment 4

8 years ago
This bug seemed to be fixed for the case shown in attachment#1 [details] [diff] [review], but not in the case of the syntax highlighter as demonstrated here: http://twitter.com/saile/status/9384830499 (see bug 547456 as well).

The patch here

http://bitbucket.org/j4c/bespinclient_queue/src/tip/fix/editor_textpainting.diff

fixes the bug for me.
Resolution: FIXED → DUPLICATE
Duplicate of bug: 547456
(Reporter)

Comment 5

8 years ago
Patrick fixed this bug in changeset 484f8091b889.
Resolution: DUPLICATE → FIXED
You need to log in before you can comment on or make changes to this bug.