Application hang, GUI closed, process not killable from task manager

RESOLVED INVALID

Status

--
critical
RESOLVED INVALID
9 years ago
8 years ago

People

(Reporter: hans.aikema, Unassigned)

Tracking

({hang})

x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [AV: McAfee][gs][has stacktrace], URL)

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-GB; rv:1.9.2) Gecko/20100115 Firefox/3.6 (.NET CLR 3.5.30729)
Build Identifier: Thunderbird 3.0.1 Build ID 20100111101938

After Thunderbird became 'unresponsive' ('this folder is being processed' messages on inboxes attempting to read the mail) I close Thunderbird. This seems to succeed (the GUI closes), but the Thunderbird.exe process keeps running without consuming any CPU.

Based on a getsatisfaction.com blog posting with seemingly similar symptoms I have now performed a WinDbg dump based on instructions posted on https://developer.mozilla.org/en/How_to_get_a_stacktrace_with_WinDbg.


Reproducible: Sometimes

Steps to Reproduce:
1. Start thunderbird
2. Use thunderbird for extended time (usually leaving it running overnight or for a day), preferably until 'loade remote images' for a mail starts to fail, retrieving mail starts to fail or reading from a message folder starts to display 'this folder is being processed' without TB reporting that it is performing indexing
3. Close thunderbird
Actual Results:  
Thunderbird.exe keeps running keeps running without consuming CPU. Clicking 'End Process' in Windows taskmanager seems to succeed (no error popup), but thunderbird.exe keeps running without consuming CPU.

Expected Results:  
Thunderbird.exe should not have kept running, and should also have terminated after the 'End process' request from the taskmanager.

I'll attach the WinDebug dump resulting from the 'how to get a stacktrace' pages in a moment
(Reporter)

Comment 1

9 years ago
Created attachment 425656 [details]
WinDebug stacktrace log

Logged result from debug-session on hung Thunderbird.exe process based on https://developer.mozilla.org/en/How_to_get_a_stacktrace_with_WinDbg instructions for hung processes

Comment 2

9 years ago
Hans, thanks for the stack. Has it been the case with every one of your hangs, that you were not able to kill the task in task manager?  

Also, if you encounter this again, try kill tree. The worked for me a couple times when normal kill didn't terminate the task.

I'm linking this to http://gsfn.us/t/o1ey temporarily because it's not likely the same issue as the reporter of http://gsfn.us/t/o1ey

no indicators this may be security sensitive, so removing
Group: core-security
Keywords: hang
Whiteboard: [gs][has stacktrace]
Version: unspecified → 3.0
Not killable means that the process hangs in a kernel mode driver.
Which Firewall and AV product are you using ?
(Reporter)

Comment 4

9 years ago
All the hangs I encountered were not killable through task manager (only resolvable by a full restart of my PC, which otherwise remains running 24/7 (hosts the primary mailserver and webserver for my personal domain).

No firewall (am on a local LAN behind and ADSL modem/router, with just a couple of explicit port forwards which I consider to be safe and which could only be further protected by an advanced IDS, not a simple firewall)

AV product: McAfee VirusScan (Security Center 9.15 (build 9.15.160); VirusScan v13.15 build 13.15.113), with Real-time scanning (on-access filescan) disabled and Email virus protection enabled.

Thunderbird mailboxes storage is on a disk that is on a Promise FastTrak TX4310 Controller drive RAID1 volume.

Comment 5

9 years ago
please try with McAfee VirusScan totally disabled
(Reporter)

Comment 6

8 years ago
Have been running without trouble now for quite some time with McAfee's Emailscan disabled and Thunderbird is running smoothly. So yes, this seems to be an issue in between Thunderbird and the McAfee Virusscan Email-scan solution.

Comment 7

8 years ago
Hans, thanks for the feedback
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
Whiteboard: [gs][has stacktrace] → [AV: McAfee][gs][has stacktrace]
You need to log in before you can comment on or make changes to this bug.