If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[BTN]BUTTON elements do not always depress when clicked

VERIFIED DUPLICATE of bug 53669

Status

()

Core
Layout: Form Controls
P1
critical
VERIFIED DUPLICATE of bug 53669
17 years ago
17 years ago

People

(Reporter: djoham, Assigned: joki (gone))

Tracking

({html4, regression, testcase})

Trunk
x86
All
html4, regression, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

344 bytes, text/html
Details
(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.15-4mdk i686; en-US; m18) Gecko/20000927
BuildID:    2000092710

If a button element is clicked for the first time, it depresses. If it is then
clicked again (without loosing focus) the button element will not be visibly
depressed. however, all events for the button seem to fire.							

Reproducible: Always
Steps to Reproduce:
Open test case I'll submit. Follow instructions on the page								

Actual Results:  The button element does not visibly depress (after the first
time) without first loosing focus							

Expected Results:  I would expect the button element to behave exactly like the
input type=button element. For comparison, the test case will have both
(Reporter)

Comment 1

17 years ago
Created attachment 15699 [details]
test case

Comment 2

17 years ago
Confirmed on Linux (RedHat 7.0) and Windows 98 using 101908 trunk build.

Comment 3

17 years ago
marking OS=ALL, confirming, adding testcase to keywords because the test case
clearly demonstrates the problem.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: testcase
OS: Linux → All

Updated

17 years ago
Status: NEW → ASSIGNED
Summary: BUTTON elements do not always depress when clicked → [BTN]BUTTON elements do not always depress when clicked
Target Milestone: --- → Future

Comment 4

17 years ago
This is a style issue. 

The HTML4 button has these rules:

button {
 ...
  padding: 1px 1px 1px 1px;
}

button:active:hover {
 ...
  padding: 2px 0 0 2px;
}

So when you press it (active) it shifts things down and to the left. It does it 
fine the first time. The first time you can set a break point in 
nsHTMLButtonControlFrame:Reflow and it hits it, if you click a second time you 
never hit the break point. 

It looks like the event state manager is somehow figuring the state hasn't 
changed. This used to work.

Assignee: rods → joki
Severity: normal → critical
Status: ASSIGNED → NEW
Keywords: html4, regression
Priority: P3 → P1
Target Milestone: Future → ---

Comment 5

17 years ago

*** This bug has been marked as a duplicate of 53669 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 6

17 years ago
VERIFIED.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.