tinglysning.dk broken in Fx3.6, works in Fx3.5, IE8 and Chrome 4.0

RESOLVED FIXED

Status

Tech Evangelism Graveyard
Danish
RESOLVED FIXED
9 years ago
3 years ago

People

(Reporter: Jesper Kristensen, Unassigned)

Tracking

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; da; rv:1.9.2) Gecko/20100115 Firefox/3.6 (.NET CLR 3.5.30729)
Build Identifier: 

The site https://www.tinglysning.dk/ is broken in Firefox 3.6, but works in Firefox 3.5, Internet Explorer 8 and Chrome 4.0.

The site belongs to the government administration, which keep track of land ownership in Denmark. Any change of land ownership (typically buying or selling a house) is required by law to be registered (typically by the real estate agent or lawyer), and this site is the only way to do so.

The change happened between
http://hg.mozilla.org/mozilla-central/rev/6673479e68ee
and
http://hg.mozilla.org/mozilla-central/rev/5c913c4662d8

and I would guess it is caused by bug 476856.

The reason is a bug in the CSS style sheet of the site containing something like this:

background-image: url(foo.gif');

In Firefox 3.5 everything after this line in the style sheet is considered a syntax error and is ignored. In any other browser only the particular line is ignored and everything after it is used.

Reproducible: Always

Steps to Reproduce:
1. Visit https://www.tinglysning.dk/ in Firefox 3.6

Actual Results:  
Most of the page except for the top menu is shifted to the right, totally out of view in an 1024px wide browser window.

Expected Results:  
Page should work like in any other browser.
(Reporter)

Comment 1

9 years ago
Created attachment 425698 [details]
Actual result
(Reporter)

Comment 2

9 years ago
Created attachment 425699 [details]
Minimal test

Minimal test, which displays a Red background in Firefox 3.6 and a green background in the other mentioned browsers.
(Reporter)

Updated

9 years ago
Blocks: 476856
(Reporter)

Comment 3

9 years ago
(In reply to comment #0)
> In Firefox 3.5 everything after this line in the style sheet is considered a

That should obviously have been 3.6 instead of 3.5. However they have fixed the problem now.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.