Offline IMAP folder not properly compacted

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
9 years ago
7 years ago

People

(Reporter: baffoni, Unassigned)

Tracking

1.9.1 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2012-01-05][needs retest])

(Reporter)

Description

9 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.7) Gecko/20100111 Thunderbird/3.0.1

I had an offline folder that was 700+ MB.  I compacted the folder online, I went offline, compacted again (actually got the message to compact all offline folders), folder was 700+ MB still.  I reindexed folder (which cleared offline files) and went offline with download, offline folder is less than 70MB.  Compacting is not removing all offline emails properly (ideally this should happen when online, but when offline, it should work as well).

To reproduce:
1) Start with stale offline folder (multiple new IMAP messages, sync, delete online, sync, new message, sync, delete online, sync, etc.).
2) Check offline folder size
3) Compact folder online.
4) Go offline, compact folder
5) Go online.  Check size.
6) Reindex, and sync for offline use
7) Check size.

Expected: size from 5) and 7) should be the same.
Actual: they are not.

Comment 1

9 years ago
Michael, do you still see this in v3.0.3?
is there a matching bug from http://bit.ly/aRnqVz ?
Component: General → Backend
Product: Thunderbird → MailNews Core
QA Contact: general → backend
Version: 3.0 → 1.9.1 Branch
Michael Baffoni, which is real total data size of the folder? 700MB? 70MB?
After "6) Reindex", was message of "<account_name> is up to date" displayed at Activity Manager window before "7) Check size"?
(Reporter)

Comment 3

9 years ago
If by "real" you mean the size of the IMAP folder on the server, it was 70MB.  "Check size" is just opening a window in the OS and looking at the file size of the offline file.
(In reply to comment #3)
> If by "real" you mean the size of the IMAP folder on the server, it was 70MB. 

It looks that all mails were downloaded when you executed step 7) after rebuild-index at step 6).

"Compact" consists of;
  i)  Request "expunge" to IMAP server
  ii) Compaction of local offline-store
      (different but similar to Compact of local mail folder)
If Work Offline mode, i) can't be executed. Tb possibly doesn't invoke ii) if i) fails or is impossible. It may depends on IMAP delte model.
What is your IMAP delete model choice?
(Reporter)

Comment 5

9 years ago
Move to trash.

Comment 6

7 years ago
Michael, can you reproduce this in version 6, and do you have any more info?

Comment 7

7 years ago
(In reply to Wayne Mery (:wsmwk) from comment #6)
> Michael, can you reproduce this in version 6, and do you have any more info?
Whiteboard: [closeme 2012-01-05][needs retest]
RESOLVED INCOMPLETE due to lack of response to previous question. If you feel this change has been made in error, please respond to this bug with your reason why.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 9

7 years ago
Reviewing, confirmed WFM on Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0a2) Gecko/20120124 Thunderbird/11.0a2
Resolution: INCOMPLETE → WORKSFORME
You need to log in before you can comment on or make changes to this bug.