Impossible to send webpape or a file that include a "," in the URL

VERIFIED FIXED in M18

Status

MailNews Core
Composition
P3
blocker
VERIFIED FIXED
18 years ago
10 years ago

People

(Reporter: Henrik Gemal, Assigned: Jean-Francois Ducarroz)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [rtm++], URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Go to:
http://www.zdnetasia.com/news/dailynews/story/0,2000010021,20072958-1,00.htm
and select File -> Send Page
This will generate 4 attachments in the compose window!
(Reporter)

Updated

18 years ago
Summary: Impossible to send webpape that include a "," → Impossible to send webpape that include a "," in the URL

Updated

18 years ago
QA Contact: esther → pmock

Comment 1

18 years ago
This issue can be reproduced in the branch build.  
 win32 commercial seamonkey build 2000-092711-mn6 installed on P500 Win98
 linux commercial seamonkey build 2000-092710-mn6 installed on P200 RedHat 6.2
 macos commercial seamonkey build 2000-092711-mn6 installed on G3/400 OS 9.04

Note: when you try to send the message, seamonkey reports that it could not send 
the attachment and ask if you would like to send the message anyway.

Comment 2

18 years ago
*** Bug 55094 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 3

18 years ago
*** Bug 56055 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 4

18 years ago
nominating rtm. Fix should be simple
Status: NEW → ASSIGNED
Keywords: rtm
Target Milestone: --- → M18
(Assignee)

Comment 5

18 years ago
but at this point, I don't think it will be approved!

Comment 6

18 years ago
I'm willing to see your simple fix in the form of a reviewed patch :-)

This could be important because entire services have been built up around
sending these types of email.  If this is broken, a lot of people are going to
see it as they forward these messages to friends and such.
Whiteboard: [rtm need info]
(Assignee)

Comment 7

18 years ago
It's a little bit worst than expected. Even if you add the web page url manually 
(using File/Attach Web Page), you cannot send the message because of the comma 
in the url. Also, I discovered that with Classic theme, you cannot remove an 
attachment!! I'll file a new bug for that.
(Assignee)

Comment 8

18 years ago
Same similar problem appends when you try to send a file with a comma in the 
name. You get a error message asking you if you want to send the message without 
the attachment.
(Assignee)

Comment 9

18 years ago
update summary
Summary: Impossible to send webpape that include a "," in the URL → Impossible to send webpape or a file that include a "," in the URL
(Assignee)

Comment 10

18 years ago
I have a solution for this problem but now I hit another problem on Mac: I 
cannot send an attachment if the file name part if more than 32 characters, this  
is the case with the URL attached to this email once I have replaced the "," 
with "%2C". The worst in with this new problem is that we failed to show an 
error. We should really fix this mess for RTM
(Assignee)

Updated

18 years ago
Whiteboard: [rtm need info] → [rtm need info] Fix in hand, seeking review...
(Assignee)

Comment 11

18 years ago
Created attachment 16856 [details] [diff] [review]
Fix for all the problems described above

Comment 12

18 years ago
r=scottip
(Assignee)

Comment 13

18 years ago
Per Alecf suggestion, I tuned up a little be the error reporting:



Index: nsMsgCompose.cpp

===================================================================

RCS file: /cvsroot/mozilla/mailnews/compose/src/nsMsgCompose.cpp,v

retrieving revision 1.203.2.2

diff -b -u -2 -r1.203.2.2 nsMsgCompose.cpp

--- nsMsgCompose.cpp	2000/10/04 19:54:06	1.203.2.2

+++ nsMsgCompose.cpp	2000/10/12 21:02:54

@@ -718,5 +718,6 @@

ShowWindow(PR_TRUE);

if (rv != NS_ERROR_BUT_DONT_SHOW_ALERT)

-		nsMsgDisplayMessageByID(prompt, rv);

+      if (NS_FAILED(nsMsgDisplayMessageByID(prompt, rv)))

+        nsMsgDisplayMessageByID(prompt, NS_ERROR_SEND_FAILED);

}



@@ -822,5 +823,6 @@

if (m_window)

m_window->GetPrompter(getter_AddRefs(prompt));

-			nsMsgDisplayMessageByID(prompt, rv);

+			if (NS_FAILED(nsMsgDisplayMessageByID(prompt, rv)))

+		    nsMsgDisplayMessageByID(prompt, NS_ERROR_SEND_FAILED);

}

}



Comment 14

18 years ago
sr=alecf, marking rtm+
Whiteboard: [rtm need info] Fix in hand, seeking review... → [rtm+]

Comment 15

18 years ago
rtm++

Comment 16

18 years ago
pdt marked rtm++ so I'm changing the status whiteboard.
Whiteboard: [rtm+] → [rtm++]
(Assignee)

Comment 17

18 years ago
Fixed and checked in both Branch & Trunk

Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 18

18 years ago
fixed in 2000101608mn6, vtrunking...
Keywords: vtrunk

Comment 19

18 years ago
Verified Fixed on trunk builds Sending test page works as expected
linux 101808 RedHat 6.2
win32 101804 NT 4
mac 101804 Mac OS9
Setting bug to Verified and removing vtrunk keyword
Status: RESOLVED → VERIFIED
Keywords: vtrunk
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.